Nvidia drivers issues

Briefly describe your issue below:


I’m a pretty new linux user. I installed the nvidia drivers as described here:

sudo apt update
sudo apt install nvidia-driver

After rebooting, the Nvidia Control Center is there and the installation seems to have succeeded, however the screen becomes fatiguing as if the refresh rate no longer were 60Hz (though in the control center it is listed as 60hz) and the image is laggy - scrolling, menus. My graphics card is an older GeForce GT 430 but it’s listed among supported graphics cards.

At the moment I have a fresh install of parrot linux with Nouveau working perfectly, and I already did a lot of experimenting and got a bunch of other stuff working, so I’d like to try to get nvidia running, but I hope I don’t break my linux again. As long as i can revert if things go wrong, I’m willing to try.

What version of Parrot are you running? Parrot Securit 4.2.2 4.18.0-parrot8-amd64

What method did you use to install Parrot? Debian GTK

Configured to multiboot with other systems? No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Fixed it, tough I did nothing interesting.

In the Nvidia X-Server Settings, under X Screen 0 you have an option “Sync to display device” between Auto and Your Monitor. The default was Auto, I selected my monitor model and now it seems to be roughly ok. Sometimes still a bit of lag when scrolling.

Installing the Nvidia driver also sets the font DPI to 92 instead of 96, go to Control Center Appearance->Fonts->Details… where you can set the DPI manually.

I don’t even know if because of the fonts I had the impression that the image was somehow broken.

That’s it all is good for me now.

Use the updated documentation for the nvidia drivers installation information here if you have any more issues (recommended even if you believe they are working for you how you installed them to avoid any issues with other packages) Nvidia driver install UPDATED

Thanks! :smiley:

I’ll assume you got it working! :blush: happy to help!

Thanks for helping me! I made a partition with a different parrot linux install just for testing. I just tested your solution today, unfortunately it wasn’t that easy. :frowning:

Bumblebee doesn’t work directly if I follow the steps in the documentation. I get a 1024x768 desktop. However, i noticed that that the screen tearing and possible refresh rate issues happen anyway after doing the system upgrade, even without installing the nvidia drivers. For now I can’t be sure if the nvidia drivers cause any problems on their own.

Well let’s figure this out then! Great idea for the test partition #mulliganPartition haha! What is the hardware you are installing the drivers for? It may be vulkan

My card is an old Geforce GT 430, Nvidia say that Vulkan is supported only for 600 series or newer.

Card specs:

VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd GF108 [GeForce GT 430] [1458:3505]
Flags: bus master, fast devsel, latency 0, IRQ 28
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e8000000 (64-bit, prefetchable) [size=128M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel

And you’ve edited the confit file for bumblebee and the one for xorg? (Are you using another desktop is a good question to ask)

Just the /etc/bumblebee/bumblebee.conf . Is there a xorg.conf anymore? I don’t remember exactly, but I looked for it as I was looking for solution and it was not there, also there was nothing in the nvidia+bumblebee documentation about it, but I’m not sure. From what I understand certain distros don’t use it anymore. Should I then make one and does the system use it then? I was using the default desktop. At the moment I don’t have parrot linux anymore as my main distro but I still have the test partition. If you’re busy don’t bother with me, or in any case there is no rush, If troubleshooting helps you figure some stuff I’d be glad to test some things and tell you the results, or at least I can try as much as my time permits. In any case, you are very helpful, thank you! :slight_smile:

1 Like

No worries, everything’s new when it’s new, everyone can cohabitation and benefit from others :blush:what documentation did you follow in order to attempt the nvidia install? Can you provide the link of the one you primarily followed?

I followed this one you previously posted: https://docs.parrotsec.org/doku.php/nvidia-driver-install-updated
I followed all the steps and edited the bumblebee conf file. Then rebooted.
The result was a 1024x768 desktop and a blank Nvidia Control Panel. I’m guessing you aren’t supposed to use the Nvidia Control Panel anyway and use bumblebee.conf (and possibly other files)?

No you should be able to use the nvidia server settings panel under system settings. I’m going to guess that the issue is with your xorg and x11 settings. I would go through synaptic and ensure your pkg versions for your drivers for nvidia related stuff match but I haven’t done much research on non vulkan era drivers and you mentioned yours is older so I don’t know too much about bumblebee related requirements. Definitely if I was a betting man I’d say you will find the issue in some sort of xorg/xserver/x11 packages or dependencies. I believe the xserver config file is located /etc/X11/xorg.conf honestly ive been in and out of most of the files pertsining to nvidia in my system at one point or another and i think ive changed everything at least one or two different ways throug the mulligan installs i had while learning how to get it working with my system so i cant quite remember what worked in the end and id rather not tell you to crash it, although i have been able to recover from tty every time and i chose to reinstall so as to not impact any future configs or pkgs (plus i did something a little better every time so it was only positives!).

You can actually suggest things that might crash my system since I have a stable os I don’t change and a test partition for the parrot distro. A good way to go about things is to install parrot on a btrfs filesystem - the filesystem itself supports instant snapshots. Then if you crash your system you can restore the previous snapshot within seconds plus a reboot. You can play around a whole day and always have a fully working operating system at hand.

Thats very true alright let me do some more in depth research, (doing it now so as long as i dont get sidetracked by dogs i should have at least a direction for you to go in an hour or so) i see you just missed the vulkan era im not sure whats before that definitely not bumblebee i dont think though. I just got everything installed in an arch partition as well so its getting easier to identify the packages and depends etc. be right back.

okay so with some digging on the Nvidia forums I found that fermi was promised but not delivered (you were indeed supposed to get included with vulkan support however they seem to have some sort of installation issue. heres the link if you want to read more: https://devtalk.nvidia.com/default/topic/917161/vulkan/fermi-support-/8 you will have to go back to using the original modules that came preconfigured with parrot so just get those reloaded and configured and youll be good to go, unfortunately that card does not seemed destined for linux life.

I don’t plan on keeping the card forever anyway, for the time being it’s good at what it does. Thanks a lot for your help! :smile:

Hah i had an rx580 till it bumped and shorted my would be server mobo somehow :pensive: #gpusaregold