nVidia stopped working after 5.16 upate via parrot-upgrade

Last night I started the new kernel update to 5.16 and when I rebooted the machine I lost my nVidia connection, my system only recognizes one of my 2 monitors and only shows in 800x600 resolution (welcome to 1992, LOL) I went and checked my grub to make sure my nouveu is off and such, which it is as no hardware has changed on this box for the 2-3 years I’ve been running parrot. I feel I have exhausted all avenues and need some help. Thanks

  • 5.16.0-12

Hello. I upgraded kernel to 5.16 and i didn’t reboot. However i noticed my FPS dropped. I guess it’s because current Nvidia driver version is not compatible with kernel 5.16. Everything we can do is wait. Either virtualbox-dkms doesn’t work. I’m telling Palinuro about this.

Anyway please try sudo apt install nvidia-driver -t parrot-backports

1 Like

Update: rebooted and everything is fine here. Nvidia driver Version: 470.103.01-1~bpo11+1, GTX 3060 on Gigabytes G5

Thanks for that but, I must of really hosed it up when I tried all my trouble shooting.
“Errors encountered while processing: nvidia-tesla-450-kernal-dkms” I’m using a GeForce RTX 3060 Ti

"when I run that command I see "nvidia-driver is alredy the newest version (470.103.01-1~bpo11+1)

Why are you using nvidia-tesla-450-kernel-dkms? RTX 3060 TI should use nvidia-driver instead, unless i’m having a big mistake (my pc is having 3060 ti and it’s using nvidia-driver as well.
My suggestion is you remove that tesla package

Thank you for all your help, I must of still had a bad package. so I did a
sudo apt remove nvidia-* removing all packages I had from the apt. Then followed th
e instructions for installing from the nvidia drivers and that worked. Nvidia drivers - Parrot Documentation

Hi!

I’m having a somewhat similar issue here. Not with Nvidia drivers, but with VirtualBox, VMWare and DroidCam.

I’d like to point out that VMWare and DroidCam were installed manually. Droidcam by downloading and compiling the source and VMWare via a .bundle file (downloaded from the official VMWare site).

I know for a fact that Droidcam needs a kernel module to work since the installation instructions tell you to compile and install a kernel module (v4l2loopback-dc), so thats probably why i’m having issues after the kernel update.

The thing is that when i try to install virtualbox-6.1 again i get this error:

linux-headers-am64 appears on the list that i get from apt list --upgradable

If i try to install the package i get this message:
Imgur

I cannot install gcc-11 neither. APT says that:

Package gcc-11 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gcc-11' has no installation candidate

Hello. We know about this problem, we are working on it.

1 Like

Ok. Thanks!