Oclhashcat: Segmentation fault

Hi. I have optimus laptop with two grapchics cards:

  • iGPU: Intel HD Graphics 630 (rev 04)
  • dGPU: NVIDIA GTX 1050

The problem is I can’t run oclhashcat or oclHashat at all.

When I am trying to run it with my Intel card i get this:

# oclhashcat:
Segmentation fault

And with the nvidia card i get no output at all:
# optirun oclhashcat:

What logs can I provide to help with the situation?

You can use hashcat instead. As I read before, this is common issue and I don’t think oclhashcat work anymore. You can search about oclhashcat in hashcat forum.

1 Like

As dmknght said, just use hashcat.

From their site:

Note : all versions of oclHashcat have been replaced by a unified OpenCL CPU/GPU version, now known simply as hashcat.


Thank’s everybody, as far as i understood you have to use -d 2 parameter to use gpu.

I’ve tried to install this driver but got no changes, hashcat still says there are no devices found and that I am running native Intel OpenCL runtime. Can I choose somehow another OpenCL?

Actually -d 2 means you have to define your hardware manually. Maybe your driver is having some issue. I have never used AMD / Nvidia graphic hardware before, but after I installed opencl driver for intel graphic driver, hashcat picked my graphic device automatically

Problem solved guys, thanks, no need to put -d 2 parameter, just running with optirun let’s hashcat correctly recognize my nvidia card. Everything works, but there is still an annoying warning
nvmlDeviceGetFanSpeed(): Not Supported at the start, but card’s temperature stays near to 70 C with standard workbase profile.

1 Like