Parrot 4.2.2 VM install issue

Briefly describe your issue below:


I’m having some issues installing Parrot Security 4.2.2 in a virtual machine, I get the same result with both the latest versions of VMWare Workstation Player or VirtualBox. I get through the install without any issues, however once it tries to boot after the install, it gets stuck on a black screen with an underscore blinking in the upper left corner.

I’m running other Linux VMs without any issues and I can even run the Parrot Full 4.1 VMDK image from, however I want to run the Security 4.2.2 image from scratch. I installed a bunch before without any issues but I even followed your VM install guide to make sure I didn’t forget anything and still same issue.

In case it matters, my PC:
Model: Dell XPS 15 (9570)
RAM: 16Gb
CPU: Core i7-8750H
GPU: NVidia GeForce GTX 1050 Ti*

VM specs:
RAM: 8Gb
CPU: 4 cores
3D accelerated graphic enabled
HD: 20Gb
Network: Bridge
USB: 2.0

What version of Parrot are you running? Parrot Security 4.2.2

What method did you use to install Parrot? Debian Standard I think, I just select Install from the prompt when the VM boots

Configured to multiboot with other systems? No I run it as a VM

If there are any similar issues or solutions, link to them below:

**If there are any error messages or relevant logs, post them below: just a blinking _ on a black screen


Quick update, I did the Ctl+Alt+F4 thing to get to the command line but couldn’t get any further:

Quick update #2, with sudo startx I was able to get in, however now it tells me that my HD is almost full:

I think it’s weird that a fresh install takes so much HD space.

I don’t get it, I installed parrot in a VM on other systems and it worked fine and even on a RPi3 and never ran into any of these issues. I there something I’m missing here?

I dont know the storage need of ParrotSec exactly,but it needs
There are a lot of tools preinstalled on ParrotSec
Use Home edition instead, if you have less storage space :slight_smile: