Parrot connects to phone hotspot but not home wifi

Briefly describe your issue below:
I dual boot my windows 10 intel hp laptop with parrot security os. It didn’t have the drivers installed so my friend installed realtek network and ethernet controller to it. Now it is not showing wifi(wpa2) connections but when I switch on hotspot on my mobile (redmi) it is showing.Can anyone help?

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

**If there are any error messages or relevant logs, post them **

Welcome to the community @Abdul_Baseer :slight_smile:

Give us the wifi card model:

inxi -N

do you see it listed when running:

iwlist scanning

(you may have to run it a couple times depending on driver)

?

Probably is a driver problem with cryptography

type

sudo iw phy

and show me the “Supported Ciphers:”

Nothing is shown

It is showing
Interface doesn’t support scanning

had an issue with a previous Intel card that initially would not connect to one of the newer 5.75Ghz networks setup by ISP. It connected after a few tries when I edited the network to 2.4Ghz (under edit connections in Network Manager).

Was curious if that could have been your problem. Have you tried other networks?