Parrot OS 4.10 doesn't recognize second monitor (AMD)

Hello, I just installed Parrot OS and I’m not able to use my second monitor. My first monitor is connected on the MB and the second one (HMDI) on my AMD RX580 (drivers already installed).

My lspci:
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7) (prog-if 00 [VGA controller])
Subsystem: Micro-Star International Co., Ltd. [MSI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
Flags: bus master, fast devsel, latency 0, IRQ 130
Memory at 2fe0000000 (64-bit, prefetchable) [size=256M]
Memory at 2ff0000000 (64-bit, prefetchable) [size=2M]
I/O ports at d000 [size=256]
Memory at efd00000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at efd40000 [disabled] [size=128K]
Kernel driver in use: amdgpu
Kernel modules: amdgpu

My xrandr:
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 16384 x 16384
DP-1 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
1680x1050 59.95*+
1280x1024 75.02 60.02
1152x864 75.00
1024x768 75.03 60.00
800x600 75.00 60.32
640x480 75.00 59.94
720x400 70.08
HDMI-1 disconnected (normal left inverted right x axis y axis)

On the settings > display, doesn’t detect the second monitor.
I tried to download the AMDGPU drivers directly from the website and install them (with the same dpkg compiler issues of everyone else of course) along with the ones provided with the OS. I rebooted and finally the second screen turned on, it was working but on the login page everything started to glitch and then the GUI crashed, I was just able to use the terminal on the black screen but without any GUI and I had to run the command “amdgpu-pro-uninstall” in order to get my GUI back (without the second monitor, again).
I tried to uninstall the amd drivers provided with the OS and install back the AMDGPU from the vendor, but my lspci wasn’t even detecting the drivers. I guess for the common dpkg compiler issue.
I tried to unplug, plug in, reboot, unplug reboot and plug in, nada.
I tried to run the command: xrandr --output HDMI-1 --auto, but it doesn’t turn on the monitor.

I’m out of option. Any help please?

PS: I dual boot with windows, and on windows both screens work.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.