Parrot OS 4.11.1 installation issue in my MSI laptop

Hi, I downloaded the latest parrot OS 4.11.1 on 25-4-2021 and tried installing into my laptop as DUAL boot but it always gave error saying " couldn’t load driver from the removable drive".
I am using MSI GL638RD laptop with 8GB RAM, core I5 processor, 128GB SSD and 1tb 7200RPM HDD.
I am trying to install the parrot OS besides my Windows 10 as I always use the same way from few years.
Issue:- always after choosing the Language and timezone when its time to mount the USB to proceed further, it gives me error “you may have to load additional drivers from removable media”
First of all my “Secure Boot” option is Disabled in my BIOS and I am trying to install the OS in UEFI mode.

  1. I tried making my USB pendrive bootable using the “RUFUS” with both ‘GPT schema’ option and also ‘MBR or GPT schema’ option and also tried in “dd mode” and “iso mode” in the same RUFUS tool. I tried Power ISO and Etcher but still no luck.
  2. I thought my usb pendrive must have some issue so I tried with multiple USB Drives like my 8gb sandisk usb 2.0 pendrive, 16gb sandisk usb2.0 , 32gb HP usb3.0 hybrid pendrrive but still using all these pendrives gave me same error.
    3)I tried using the “Install” option and also " GTK install" option but still the same issue.
  3. I tried to manually mount the usb drive by using “Execute a shell” option to fix this error but the none of the USB drive wer not detected as i ran “blkid” command except my SSD and HDD were always properly detected.
  4. Then I tried installing by choosing the “Live” option and then choosing the “install” Icon from desktop and it went to installing system screen and gave me some random file errors and after trying 2-3 times installing in same Live mode finally it got installed but the issue began with my WiFi adapter as it showed sometimes after booting parrot os and sometimes didn’t show any wireless adapter even after fully upgrading the OS using “sudo apt full-upgrade”
  5. I tried installing the same parrot 4.11.1 in my virtualbox using the standard install and GTK install options and landed with same error " couldn’t load driver"
    Team Kindly, check if any issue is there as until now I had no such problem with parrot OS or any linux distro in my any system, Even parrot os 4.9 runs without any single error.I even tried downloading the ISO of 4.11.1 twice but still same issues.
    Please check and update team as I really love this OS for my pentest learning purpose and its the best even compaired to kali OS as per my personal review.