parrot updater error "Source list error Missing Parrot repository"

I think Synaptic broke my parrot updater. I’ve opened Synaptic to check what repositories it is using, and when I’ve opened repositories list, pop-up showed up something like “Ignoring invalid repositories”. Then when I’ve double-clicked “Check for update” by parrot updater, the information showed up “Source list error Missing Parrot repository”. Does anyone know how to fix this? I’ve tried to reinstall parrot-updater, but this didn’t helped.
I know this isn’t big issue, I can update by parrot-upgrade but I would like this to work.
I just want to say I did not change anything in repositories manually.
I use Parrot Release 5.0 (Electro Ara) 64-bit, Kernel Linux 5.16.0-12parrot1-amd64 x86_64

Can anyone help?

Hi @MGsid ,

My guess would be to check your parrot.list file (with Synaptic closed),

sudo pluma /etc/apt/sources.list.d/parrot.list

Then check that only the following repositories are uncommented,

deb parrot non-free contrib main
deb parrot-security main contrib non-free
deb parrot-backports main contrib non-free
deb parrot-updates non-free contrib main

(Yeah, a little work due all the extra mirrors and comments. But I like having all the repo mirrors available to un/comment.)

@Masmer Thanks for help,

I’ve uncommented parrot-updates but unfortunately, this didn’t worked. The repositories currently in use (uncommented) are:


deb lts main contrib non-free 
deb-src lts main contrib non-free 


deb parrot main contrib non-free 
deb parrot-security main contrib non-free 
deb parrot-backports main contrib non-free 
deb parrot-updates main contrib non-free

But when I use sudo parrot-upgrade these are used

Hit:1 lts InRelease
Hit:2 parrot InRelease
Hit:3 parrot-security InRelease
Hit:4 parrot-backports InRelease
Get:5 parrot-updates InRelease [14,6 kB]
Get:6 parrot-updates/main amd64 Packages [17,7 MB]
Get:7 parrot-updates/contrib amd64 Packages [111 kB]                                      
Get:8 parrot-updates/non-free amd64 Packages [208 kB]  

It looks like there is missing one LTS repo. Maybe parrot updater has some other list? Just a gues?

I have that line commented out. Maybe “Source list error” has something to do with the deb-src?

This is my parrot-upgrade output:

└──╼ $sudo parrot-upgrade
Get:1 lts InRelease [14.6 kB]
Get:2 parrot-security InRelease [14.3 kB]
Get:3 parrot-backports InRelease [14.5 kB]    
Get:4 parrot-updates InRelease [14.6 kB]      
Get:5 lts/main amd64 Packages [17.7 MB]       
Get:6 parrot InRelease [14.6 kB]  
Get:7 parrot/main amd64 Packages [17.7 MB]
Get:8 parrot-security/main amd64 Packages [285 kB]
Get:9 parrot-backports/main amd64 Packages [733 kB]
Get:10 parrot-backports/non-free amd64 Packages [20.6 kB]
Get:11 parrot-updates/main amd64 Packages [17.7 MB]

I use the mirror in Italy as the repo always seems to be up-to-date when the U.S. mirrors are wonky.

I’ve uncommented this mirror in parrot.list and for some reason it started working again:)

deb parrot main contrib non-free

It was strangely edited like ##deb deb https://mirrors

I’ve had the same problem with Parrot 4, but I couldn’t find the solution back then.

Anyway, thanks for help. Problem solved:)

Thank you MGsid I have taken your mirror recommendation

easier editing with Synaptic - “caja-admin”


The Alibaba Cloud Sourcelist works for me →

deb parrot main contrib non-free 
# deb-src parrot main contrib non-free 
deb rolling-security main contrib non-free 
# deb-src rolling-security main contrib non-free 

Kind Regards

@dks84 Glad to help! Cheers!