Parrotsec install stuck after partition

Hey everyobody,
I tried to install parrot security on my ACER Aspire ES 15 model ES1-533-P205 this is after Debian 9 installed & was working fine for 2 months & parrotsec works fine in live mode as well. So I checked that the md5 signatures match & the do.

During install I tried 2 approaches:

  1. I chose to auto-configure with the largest space with one root partition & one home partition & using the recommended filesystems xfs & btrfs. that’s when I get the first error: the installer complains that there isn’t a swap space. So I go back & try with other filesystem combiniations until I tried ext4 as a last resort on both those partitions. So then I try:

  2. going back to the partition menu, making a swap partition & installing again & that’s when I get the following error “steps that failed: configuring the package manager”

version: Parrot-security-4.5.1_amd64 (I chose this version because I want to eventually become a white hat hacker even though this will be on my personal laptop)

What method did you use to install Parrot?
live usb

Configured to multiboot with other systems?
yes with windows 10

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
Warning: there is no swap partition or If I make one then I get the following error “steps that failed: configuring the package manager”

Thanks for your time

1 Like
  1. Ohk man, select manually partition
  2. then Delete whole Partition in which You want to install
  3. Then Enter & give automatic Partition

It will do Everything fine for you

I’m sorry I didn’t explain properly. Before every attempt I delete all the linux partitions and proceed from there

Then I think in installation also you able but

Live boot & create partition via Gparted😛

Hey Amzker,
I thought that Gparted is used by the installer in the partitioning step; or does the installer use KDE Partition Manager? Do you mean that I should start Gparted that comes with Parrotsec outside the installer?

please tell me that that you didn’t mean to say, “Use the recommended setting/arrangement/steps in the proceedure with the liveUSB installer” as I think I was very clear that that’s what I already attempted many times

Best regards

How did you created bootable USB?
Use etcher for making bootable USB.

I am talking about auto partition

  1. At partition part select that partition in which you wanted to install
  2. DELETE that Partition (hit enter on partition , you get option for delete)
  3. Now you see FREEE SPACE
  4. Enter on it & select automatic Partition & saprate
  1. Now live boot and open Gparted | parted
  2. Create Partition Table
  3. Create ext4 Partition
  4. boot into installer & follow autopartition steps which i say before

NOTE: This issue maybe because not perfect created bootable USB (2)

1 Like

Thank you for clarifying but just a few more questions:

  1. Are you recommending that I don’t create a swap partition because that isn’t reated automaticaly

  2. I used the latest version of rufus is that not just as good as etcher?


PS I think I’m going to start following

  1. Not need now , asper we used btrs partition [OpenSuse]
    Auto partition do best for you

Rufus is Good , but

  1. Rufus is for Windows ISO
  2. Etcher is best for Linux ISO
  3. Lili USB Creator For Linux

We recommended etcher

And best way is DVD [No issue You get]


I can’t use etcher here’s what it looks like when I try to browse for the parrot image file:

I can see the text no problem if I open a folder separately

This one is not etcher
Wait i sends

Download for your win10 & make bootable USB

ok thanks
I took it from wget because I’m in parrotsec liveUSB right now

best regards

Nop, boot into windows
And make bootable USB

1 Like

So I tried everything you said to do

  1. I booted in win to make liveUSB with etcher - successful

  2. I started gparted & deleted the linux partitions & then created one big partition in ext4

  3. I then started the installer & used it’s partition utility to delete the ext partition

  4. then I used the guided partitioning to automatically make partitions with a separate home partition (no swap partiton this time) & get the following error:

    An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Configure the package manager

Best regards

Now here is not your any fault,

I will download and check that ISO And check

For now install old ISO :roll_eyes:, & install with this steps

  1. Well i think officially ISO have error , because configuring APT i don’t think need internet , so we also not able to include internet issue
  2. we installed this ISO 4.5.1 without error ( i think it’s 4.5) , so thus point make me think that no it’s not ISO fault
  3. i will give try , for now you download & install Parrot 4.5
    @admins maybe look at this

Go with this

Hell yeah i forget. Cam you give install.logs at
Or ALT +F4

Try grabbing the 4.6 release(it’s stable enough), 4.5.1 is about three or four updates behind at this point. Also when you make changes with live usb you should reboot before starting the installer again

Will do but where can I find version 4.6? can’t find it
After a complete install I thought that I had to reboot after a complete install - I don’t know how to start the new OS without rebooting but thanks for mentioning this

Best regards

Haha, my bad I thought we were on 4.6…you can disregard that part but if you want the testing in the archive parrot>iso>testing

I was thinking a newer version might help because package management can be affected by time/date/release synchronization oddities…but that’s not actually an issue here I suppose. Now on to what I meant was that if when you’re setting up partitioning in the live mode for an installation after you make changes to the partitioning(ex. preformating one large partition, erasing all the volumes you want to get rid of, resizing windows, etc.) that you should reboot after doing that before booting into the installer. However as I understand it you have performed a successfull installation if so I guess you can disregard that as well…
If you are still runnign into trouble with configuring package manager you can try erasing all the data on the disk space you want to install in as opposed to just delete the previous partitions, try connecting an ethernet cable to the machine during installation so it can go online beyond that you may just have to keep trying sometimes it’s really hit or miss.
Oh and I don’t know of a way to start the os without rebooting after install either, doesn’t sound like a good idea either

So I tried version 4.5. Etcher completes & sats that it failed. Upon investigation the .torrent doesn’t match it’s md5 signature. I tried 3 different torrent files & they all have the sigatures between them but none match the published signatures.

best regards

Now i not undetstand what’s going on :thinking::thinking:,

  1. 4.5 also not install??
  2. where you get error
  3. plz send logs of install (4th tty)

Other OS install well?

I haven’t tried to install this one after getting it from bittorent because etcher gives the above error after completing the liveUSB (ie etcher completes the write but tries to verify that it is written properly by checking the checksum & the result is they don’t match) This is probably because the .torrent file’s checksum didn’t match.

So should I be worried or should I just try to install it anyway?

Best regards