Partitions unmounted after dualbooting Parrot

Recently, I had tried Parrot OS 4.8 MATE Security on my 2018 Macbook Air. I used the Debian Standard method. What I had done is made two partitions on my macbook, one where the file systems would go and one where I would use as my swap drive. After my system had finished the installation, it had told me it was downloading the grub boot-loader but unfortunately, it was stuck on 50% for a very long time. I decided to power off my system and boot into Mac OS so I could install refind when i checked Disk Utility and saw that both of my drives had been unmounted. I pressed the mount button, but no luck. I opened upon the terminal and did the following:

$ mount -t vfat /dev/disk0s5 cdrom/

mount: realpath /Users/*****/cdrom: No such file or directory

Then I decided to load up my bootable drive which i had Parrot OS on and when I was in. I pressed CTRL + ALT + F2. Then i had done blkid.

Here’s what came up: https://i.stack.imgur.com/owW1a.jpg

After i had seen the drives i had decided to try the following:

mount -t /dev/nvme0n1p5/

mount -t /dev/nvme0n1p5 cdrom/

mount -t /dev/disk0s5/

mount -t /dev/disk0s5 cdrom/

Unfortunately, none of them had worked. Here is a picture of my drives:

Disk0s3 = Swap Drive. https://i.stack.imgur.com/Uhq7n.png

Disk0s5 = Parrot OS Drive. https://i.stack.imgur.com/jpoRj.png

Could anyone tell me of a way to mount my drives again?

Thank you!

Yo. I have a couple answers as to why your drives won’t mount.
First, let’s talk about /dev/disk*:

```mount -t /dev/disk0s5/``` 
```mount -t /dev/disk0s5 cdrom/```

macOS uses /dev/disk* in Disk Utility (or diskutil in the command line). It is synonymous with dev/[sd*, sr*, nvme*...] that we see in Linux tools like fdisk, blkid, or lsblk. The Linux tools do not know about macOS naming conventions and vice-versa. So basically this means that if you try to mount a drive called /dev/disk0whatever, Linux just looks at you dead-eyed and says, “Bro… I have no idea what you just asked me.”

Second fun fact: Linux doesn’t play well with hjfs or apfs file systems, and macOS doesn’t play well with ext* Linux file systems. They just don’t know how to read the formats out of the box. There are some proprietary non-free tools out there (Paragon), but, you can reboot your computer to the other OS for free :slight_smile: There are a couple open source projects on Github that can at least open APFS-FUSE drives on Linux that you may wanna check out. https://github.com/sgan81/apfs-fuse

Let’s see, what else…
Buhhhhhh, Oh right. I didn’t see anything called cdrom in your blkid output. And also that ls somedirectoryoffthescreenIcantseeinyourpicture/cdrom/ returns not found (unless the picture is cut off and I’m just missing something). If it_is_ actually not appearing as a result… It doesn’t exist (at least in the eyes of the OS). Can’t mount null :slight_smile:

I guess the main question now is, what is the end goal?
A successful duel boot install of Parrot and macOS?
A full, single OS installation of Parrot on the Macbook?

Depending on what you’re trying to do, simply mounting individual partitions might not actually be something we need to worry too much about. Anyways let me know and lets try and get your system running :dove:

When I booted up the Parrot OS USB. I used ‘blkid’ and I tried mounting the partitions with those names as well. For my partitions. I set the Parrot OS and SWAP Partitions as MS-DOS. I also tried mounting without using cdrom and I do not believe it returned with ‘not found’. My end goal is to have parrot OS while also keeping Mac OS. Essentially, I would like to perform a successful dual boot of Parrot OS and Mac OS. I have already installed the Operating system onto the Parrot OS Partition, it is just the matter of mounting them. I will also be using rEFInd so I can select between Parrot OS or Mac OS at startup. I do apologize for responding quite late.