hello, guys I am running parrot 4.4 32bit Kernel Linux 4.18.0-parrot10-686-pae i686 MATE

install method Debian standard

**Configured to multiboot with other systems? yes, Windows 10, Linux Mint 19.

The system works great. The only bug I have found is that the plume editor will launch upon installation, but after performing the initial update to the system, it will no longer launch. I have removed the program and re-installed it to no avail. Perhaps you have some insight into this problem as I like to use the editor. if not, I will use something else to edit. Thanks.

use gedit if you like GUI editor but try using vi, it is very powerful after you learn shortcut and key control etc

1 Like

You Able to Use nano
Also Best is Scite
Download Scite by apt
Also VI is Good But Very Confusion Creates Sometime

pluma is more advanced than gedit, and while gedit is strictly chained to the gnome environment, pluma was born for mate as a clone/enhancement of the old gedit version before gnome removed a lot of interesting features from it.

if pluma does not work after a system update, then the solution has nothing to do with changing the default mate editor, but a good solution involves checking the problem, identifying it and fixing it at the source in order to make pluma work again

1 Like

could you please open a terminal window, type “pluma”, hit return and send us a screenshot of the output?

also remember to run

sudo parrot-upgrade

and reboot

for sure fixing is better than changing but i dont want to make like you and saying update when he said he purge and reinstall it and update dont do anything… so if he must work quickly before waiting your shitty answer he can use gedit/vi… and like he ask for another editor too, i answer him…

This forum is really sh.tty… dev and admin dont answer for problem, they never help users or when they answer the only one is update and reinstall… never saw asking for logs, or like the apache/nginx problem, you dont ask for a netstat when we can see “adress already in use”…

When i get over to parrot today, i will do that. I use vi also, just wondered what happened to the plume editor after the initial update. No big deal, just wanted you guys to be aware of the problem.

arning: private-lib feature is currently available only on amd64 platforms. bet this is the problem, i use a 32 bit machine for parrot.

most of the problems are common problems that happen frequently and that have tested and well known solutions.

expert people on this forum offering a hand are few compared to noob guys asking for help, and common problems are answered with common answers were possible.

if you don’t like the way “experts” answer, then help us helping people in a better way


Updates change or fix, whats your issue with that? Im sorry you feel we dont respond enough or on time, users that fail to provide details that are necessary dont exactly have a high priority over other users that for example are here to learn or improve their skillsets. Just an observation though, if you perhaps become kinder and less crass and derogatory you may have a different experience here. I dont think that any of the mods or community members have been unreasonable towards you given the replies and insults i typically see coming from your account. I cant speak for anyone else but i will continue starting fresh and disregard the prior insults regardless and i try not to comment on them as it is mst of the time none of my business unless it affects our community. If you need to talk or message me privately for issues or errors regarding your system you are free to do so my friend and will be for the foreseeable future, i only ask you be polite. If there are any more specific instances you feel could be addressed differently (like the logs you mentioned) that would benefit everyone or even just one party i encourage you to message me with them so i can at least try to improvenhow i handle business here.

LOL did you ever see me posting for problem??? never… so dont ask me to PM you for whatever… i talk for others like this guy, like the guy with the apache/nginx problem and the 90% of post here… thats the only forum about a disctro where you can see that…
for sure detailed post have high priority(LOL again) but noobs(understand beginner thats not pejorative) dont know where are the logs and/or what logs to provide… thats why on every linux forum we ask for doing netstat etc command… and not only doing apt full-upgrade…
And “expert” like you please… we could saw you answer even if you dont know the answer and googled it 5min before like VPN and TOR so please
We cant help guys when you only say go update… they saw that they leave this forum ASAP without coming back…
Look kali, debian, ubuntu, fedora, even arch forums and you never saw an admin like palinuro say in 90% of his post for problem just update…

There is 2 guys who are awesome helpfull here, one i dont remember the nickname and kidclown!!! other just ask if the parrot is up to date and others says go update, and for some problem we have Nico who google it fast and answer thinking he know what he is talking about…

Well, the pluma issue seems to be the least important issue. I surely didn’t intend to start a war in here. From here on out, if i do encounter a problem, i will not post it here, i will attempt to solve it myself. People in the world no longer know how to communicate effectively nor politely.

i sincerely apologize for hijacking your thread i promise it wont happen again, i assume you are still having issues, and youve most likely tried the apt remove --purge command, did you restart before attempting to reinstall? i cant think of why pluma would be firejailed but i suppose you could try running

firejail --noprofile pluma

but other than that rl1k was on the right path with suggesting more logs be requested to verify the issue

again, I really am very sorry that this happened and i was definitely not thinking about what post O was necesarily replying to (support not ignore lol) and ill send you a message with my email I use for support cases privately so you may message at any time and skip things like this (at this point im just feeling like an ass so im gonna stop here)

The issue is going to be pluma with parrot. I have no issue as i will simply use another editor, im not particular. As I previously stated, I wanted the team to be aware of the problem. We can now close this thread. The problem as I see it is that pluma updated with a 64bit version, and I run a 32 bit machine.

Unfortunately since most run 64 bit that is most likely going to always need manual configuration to install the 32 bit version for your specific needs. With parrot focused more on current and future tools that need more substantial hardware not as much thoughtt may go towards tthat architecture because they simply dont encounter any of it for the most part, that wouldvexplain why i was confused, its just not something in the forefront of a non i386 users mind.

Yes, I’m agree with you that VI or VIM( Vi IMproved) so powerful and it will be always the best to edit text files.