Problem installing Parrot 4.11

Dear Parrots(?),

I want to learn Linux and eventually some (basic)knowledge about cybersecurity. After I stumbled upon ParrotOS (on HTB) I thought this is the one I have to get!

I have an old laptop laying around doing nothing which is perfect to install ParrotOS on. The laptop is a
Toshiba Satellite Pro (NB10-A-12P)

From the Parrot website I downloaded this ISO:
Version: 4.11 AMD64
Desktop Environment: Mate
Edition: Security Edition

Since the laptop is not able to run CD’s I used Etcher to Flash the ISO to my (formatted) USB stick.

When I fire up the laptop I get the screen where I can choose between Live, Advanced and Install.
When I select install and entered the language and keyboard settings it starts looking for installation media.
Here starts the fun, I get a red screen with the following message:
Incorrect installation media detected, the detected media cannot be used for installation. Please provide suitable media to continue with the installation.

I rebooted and chose the ‘Live’ option which works fine. On the Desktop there is the ‘Install Parrot’ (The Calamares) and I ran it, entered all my preferences and at the Partitions part I tried both Replace a partition and Erase Disk (No Swap).

With the Replace a partition I see this: The EFI system partition at /dev/sda1 will be used for starting Parrot OS.
Current: sda1 is 300.0 MiB FAT32 and sda2 465.5 GiB Btrfs
After: sda1 is 300.0 MiB FAT32 and Parrot 465.5 GiB Btrfs

After the installation is finished I reboot the laptop without the USB plugged in and it works!

I shut it down and start it up later. And I get the message Reboot and select proper Boot Device or insert boot media in selected boot device and press a key.

Anyone knows what might go wrong here?

Thanks in advance!

For people with the same problem, I managed to install ParrotOS.

What I did:
In the Boot menu (F2 on startup) I chose CMS instead of UEFI.

After this I booted in Live mode and used the installer on the Desktop. I replaced the disk and this time it worked (don’t forget to remove the USB before rebooting).