Problem installing virtualbox

– Please Write here your help request –

Dear Parrot enthusiasts

I have a problem with installing Virtualbox showing the error below.

Can someone tell me how I can resolve this or an alternative way to install Virtualbox.



  • ParrotOS iso in use:

  • Application used for flashing the iso:

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:


Hello! As you can see a libvpx5 dependency is missing, install that and you can proceed. Alternatively, install VirtualBox via terminal sudo apt update && sudo apt install virtualbox. For further informations here’s our documentation: Install Parrot on VirtualBox - Parrot Documentation

Thanks @danterolle !
I managed to install in via command line !


Great, you are welcome!

Congratulations on your installation, @Tosh . If there is any performance issue (i.e. slow) in using VirtualBox - make sure to set Settings properly and / or give it more resources in case needed.

I’ve been able to do this before, but with a fresh install of 4-11.2 and sudo apt update;sudo apt install virtualbox I am running into

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 virtualbox : Depends: libc6 (>= 2.32) but 2.31-13+deb11u2 is to be installed
              Depends: libgsoap-2.8.117 (>= 2.8.117) but it is not installable
              Depends: libstdc++6 (>= 11) but 10.2.1-6 is to be installed
              Depends: libvpx6 (>= 1.10.0) but 1.9.0-1 is to be installed
              Recommends: virtualbox-qt (= 6.1.28-dfsg-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I was able to get to to install and work with vagrant up, but I needed this older version (virtualbox-6.1_6.1.26-145957~Debian~bullseye_amd64.deb) rather than the current to avoid this business

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.