Problem with a broken package

When I gonna install package, It’s error:

 Sélection du paquet megasync précédemment désélectionné.
(Lecture de la base de données... 438334 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de megasync-Debian_9.0_amd64.deb ...
Dépaquetage de megasync (3.7.1+3.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de megasync :
 megasync dépend de libmediainfo0v5 (>= 0.7.56) ; cependant :
  Le paquet libmediainfo0v5 n'est pas installé.
 megasync dépend de libraw15 (>= 0.16.0) ; cependant :
  Le paquet libraw15 n'est pas installé.
 megasync dépend de libzen0v5 (>= 0.4.31-2~) ; cependant :
  Le paquet libzen0v5 n'est pas installé.

When I do

sudo apt --fix-broken install 

It’s error again!

help me guys

Remove that packge

apt remove (package name)

Also able to do
Update /etc/apt/sources.list

whatever I do, error
update or upgade or install
I tried update /etc/apt/sources.list , in the extraction is error

There are missing libs and they are not on the repo. You must install manually.

apt --fix-broken install
apt-get install -f

parrot-upgrade is the best way to upgrade a parrot system.

1 Like

I tried update /etc/apt/sources.list , in the extraction is error

Remember that the sources repo list is at /etc/apt/sources.list.d/parrot.list NOT the Debian standard ‘sources.list’

@s1udge. Had a replicate of this issue with the installation. This is the terminal output:

Selecting previously unselected package megasync.
(Reading database ... 454405 files and directories currently installed.)
Preparing to unpack megasync-Debian_9.0_amd64.deb ...
Unpacking megasync (4.0.2+1.2) ...
dpkg: dependency problems prevent configuration of megasync:
 megasync depends on libmediainfo0v5 (>= 0.7.56); however:
  Package libmediainfo0v5 is not installed.
 megasync depends on libraw15 (>= 0.16.0); however:
  Package libraw15 is not installed.
 megasync depends on libzen0v5 (>= 0.4.31-2~); however:
  Package libzen0v5 is not installed.

dpkg: error processing package megasync (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.62) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Processing triggers for bamfdaemon (0.5.4-1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:

Had tried manually downloading the required dependencies but to no avail.

Current version of megasync was made for Debian 9.0, and our Parrot is based on Debian 10. megasync team said version for Deb 10 would be released soon (from github)


Megasync has a new version for Debian 10. I think it should work fine with our Parrot OS. It has been released few days ago.