programs don't see my network drive.

I am using parrot-os home.
And have been having an issue where programs don’t see my network drive.

I keep a lot of my files in on a SMB server on my local network.
I can connect to the server fine in my file manager and can view all the files.
However if I try and open the files in a program, (like VLC) it won’t access the network drive.

I ran into this problem today with my music collection.
When I select an mp3 file VLC will fail to load it as it can’t see the network location.
And when I try and manually navigate to the file in VLC the network drive does not appear for VLC.

However if I copy and paste a file from the drive to a local folder VLC will recognize and play it.

This problem affects more then just VLC though, I can’t access my network drive from most programs.

The only work around is to copy and paste the file into a local directory on my machine first.

If anyone could help that would be great.

Thanks in advance for any help.

This will be a firejail issue ( it is restricting access to your network drives.

thanks for the help, I’ve looked through the parrot firejail documentation and the firejail site’s documentation.

I’ve messed around with firejail, and am not really sure what needs to be changed.

For some reason Rythmbox audo player can read the network drive files, so I tried to compare the VLC firejail profile to the rythmbox profile, but nothing really stands out.
I also tried the firejail GUI (firetools) in hopes that it would make it easier to figure out the issue but no luck.
I’ve also tried the --clean command on VLC…

Sorry for the noob-ish questions, I’ve never used firejail before… And am kinda stuck…

Thanks for your help!

So lets just confirm that that firejail is the issue first. We can start vlc or another program without a firejail profile using

firejail --noprofile vlc

Then try accessing your network drive. If it works then we need to modify your firejail profile, if not then we will have to think of other potential causes of the problem.

Hi, I tried that and it did not work,
I don’t know whats going on… I’ve attached two screen shots to show what is happening.

In this first screen shot vlc is running with the “–noprofile” in the terminal.
The normal Caja file manager is on the right with a test folder located on the network drive. The other file window open is the VLC file selector to show that the network drive is not appearing in the side pane.
(it is not under other locations either).

In this second screen shot, this is what happens if I try and click the test file directly. I just get an unacessable error.

I’ve tried both Caja and Nautilus flie managers and they both regonize the network drive…
I just can’t browse to it or open files from it within VLC, or most other programs for that matter for various other types of files.
The only program I can play audio directly from the drive with is rythmbox.
MPV media player and VLC don’t work.

I hope this helps.
Thank you so much for all the help.
Have a great day.

As i understand, you can access your file using smb protocol. Run file from remote drive always work for me. From your image, i’d suggest you try download your file and view it from your local drive, to make sure it work (error is not from vlc side). You should verify your file also.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.