Pycurl not compiled against Openssl

Briefly describe your issue below:
Warning: Pycurl is not compiled against Openssl. Wfuzz might not work correctly when fuzzing SSL sites. Check Wfuzz’s documentation for more information.

TheHarvester does not work in any site with ssl… this problem was spotted by me today… and it replicates in a virtual machine which is in the last patch…

However it does work fine in Parrot 3.11 ( I tried inside a virtual machine).

Anyone knows how to fix this? Would be appreciated although I can still make it work in a vm with 3.11…


What version of Parrot are you running? (include version, edition, and architecture)
Linux parrot 4.16.0-parrot12-amd64 #1 SMP Parrot 4.16.12-1parrot12.1 (2018-05-28) x86_64 GNU/Linux
-> This is the last stable version. The last patch before this one also stopped working in a vmware.
No problems with 3.11 as most folks knows.
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
No
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
Warning: Pycurl is not compiled against Openssl. Wfuzz might not work correctly when fuzzing SSL sites. Check Wfuzz’s documentation for more information.

I did it and works perfectly for wfuzz :wink:

mkdir ~/python-pycurl-openssl
cd ~/python-pycurl-openssl
sudo apt-get source python-pycurl
sudo apt-get build-dep python-pycurl
sudo apt-get install libcurl4-openssl-dev
sudo dpkg-source -x pycurl_7.43.0.1-0.2.dsc
cd pycurl-7.43.0.1/debian/control
sudo sed -i ‘s/libcurl4-gnutls-dev/libcurl4-openssl-dev/g’ control
sudo dpkg-buildpackage -rfakeroot -b
sudo dpkg -i python-pycurl_7.43.0.1-0.2_amd64.deb

2 Likes

and with 2seconds of google you can find the same solution … https://github.com/xmendez/wfuzz/blob/master/docs/user/installation.rst

1 Like

Thank you, I entered into that link you posted before in fact but had not much time to solve that before.
In the end I could not try to do your solution however because I reinstalled the Os to make some needed changes (and so far I have not get this problem).
Will write back if any issue arises and when I fix in virtual image but hopefully this would solve the problem.

and i forget this command
sudo apt-mark hold python-pycurl
because if we dont make that the next update you make you will have the same problem again because he will download and install the GNU version of pycurl

that take 2min to make this all change so dont say you dont have time when you reinstall completly…

1 Like

Got a problem because when doing sudo apt-get source python-pycurl tells me…
‘E: You must put some ‘source’ URIs in your sources.list’
My /etc/apt/source.list do have two repositories although ‘MIGRACIONParrotDoc2.0’ says it must be empty…

Take look at etc/apt/sources.list.parrot
The default source list is /etc/apt/sources.list.d/parrot.list

1 Like

@g0rbe thanks

Still got this…
sudo apt-get source python-pycurl
Reading package lists… Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Packages (contrib/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Packages (contrib/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Translations (contrib/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Translations (contrib/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Packages (non-free/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Packages (non-free/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Translations (non-free/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
W: Target Translations (non-free/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list.d/parrot.list:2
E: You must put some ‘source’ URIs in your sources.list

But those two files only have inside one repository…

I can download the python-pycurl source.
Just uncomment the

deb-src http://deb.parrotsec.org/parrot/ parrot main contrib non-free

line in /etc/apt/sources.list.d/parrot.list
and
sudo apt source python-pycurl download it.

1 Like

@G0rbe
sudo apt source python-pycurl
Reading package lists… Done
E: You must put some ‘source’ URIs in your sources.list

Same problem. What the hell.

show me the output of
/etc/apt/sources.list
/etc/apt/sources.list.parrot
/etc/apt/sources.list.d/parrot.list

ah, do you apt update before download source?

cat /etc/apt/sources.list.parrot
# This file is empty, feel free to
# add here your custom APT repositories
# The standard Parrot repositories
# are NOT here. If you want to
# edit them, take a look into
# /etc/apt/sources.list.d/parrot.list

# If you want to change the
# default parrot repositories by selectng
# another localized mirror,
# then use the command
# parrot-mirror-selector
#
# and see its usage message to
# know what mirrors are available

cat /etc/apt/sources.list.d/parrot.list
## stable repository
deb http://deb.parrotsec.org/parrot stable main contrib non-free
deb-src http://archive.parrotsec.org/parrot stable main contrib non-free

cat /etc/apt/sources.list

# deb cdrom:[Debian GNU/Linux 4.1 Parrot - Official free
#deb cdrom:[Debian GNU/Linux 4.1 Parrot - Official
# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

I did not apt update Sorry.

sudo apt source python-pycurl
Reading package lists… Done
Picking ‘pycurl’ as source package instead of ‘python-pycurl’
NOTICE: ‘pycurl’ packaging is maintained in the ‘Git’ version control system at:


Please use:
git clone https://anonscm.debian.org/git/python-modules/packages/pycurl.git
to retrieve the latest (possibly unreleased) updates to the package.

sudo apt-get build-dep python-pycurl
Reading package lists… Done
Picking ‘pycurl’ as source package instead of ‘python-pycurl’
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED:
libcurl4-openssl-dev
The following NEW packages will be installed: etc

Wondering if this means the bug will be fixed with this in the end. Currently in the downloading stage.

sudo dpkg-source -x pycurl_7.43.0.1-0.2.dsc
gpgv: unknown type of key resource ‘trustedkeys.kbx’
gpgv: keyblock resource ‘/root/.gnupg/trustedkeys.kbx’: General error
gpgv: Signature made Thu 01 Feb 2018 04:12:45 PM EST
gpgv: using RSA key 7C610494944FC81DA6485696D2179D5B8A1ED011
gpgv: Can’t check signature: No public key
dpkg-source: warning: failed to verify signature on ./pycurl_7.43.0.1-0.2.dsc
dpkg-source: info: extracting pycurl in pycurl-7.43.0.1
dpkg-source: error: unpack target exists: pycurl-7.43.0.1

No… stuck again…

check this:
http://pycurl.io/docs/latest/install.html

I was getting this error please help :disappointed_relieved:

This is not a real problem since that’s work perfectly with ssl even with the error…

“src/pycurl.h:164:13: fatal error: openssl/ssl.h: No such file or directory
" # include <openssl/ssl.h>”

I have the same issue, but, no theharvester is not inproved, it keep saying Pycul is not compiled against Openssl.
Is there a way to get through this error of compilation ?
Thanks

I’ve found
I had install this
sudo apt-get install libssl-dev
and the compliation worked, don’t ask me why

oups I have spook too quickly, there is an other error.

make[1]: *** [debian/rules:52: override_dh_auto_install] Error 1
make[1]: Leaving directory ‘/root/python-curl-openssl/pycurl-7.43.0.2’
make: *** [debian/rules:26: binary] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary subprocess returned exit status 2

I’ve sent all the morning… and this f*** is still not working…

not true at all !!! Compile for source is ALWAYS time comsuming because there is ALWAYS errors libraies you don’t have etc.
I this case, no exception, you will suffer and spend hours… like ALWAYS

I gave up and tried theharvester in another distro with theharvester included, so not sure how to fix it yet (as you say, it can take a lot of time if luck is not in your side)