"Reboot and select proper boot device" after installing

So basically I was trying to help a friend install parrot home edition on a old system for it being lightweight and easy to use. She was using Garuda Linux before but due to only having 3GB of RAM decided to go something lighter. We flashed the ISO with Balena Etcher and went through the installation normally as suggested in the documentation. After finishing the installation the OS won’t boot up appearing a message “Reboot and select proper boot device” as if it doesn’t detect the HDD as a bootable device and can only boot the USB drive.

-UEFI mode is enable, also tried CSM, with no success;
-Multiple tries installing with no sucess including manual partitions;
-Trying changing boot priority and it is correct but no sucess;

  • Application used for flashing the iso:
    -Balena Etcher

  • Screenshots:
    In this screenshot we were trying the CSM mode boot, but still same error as UEFI mode.

I’m totally lost on what the problem is, anyone seen this before?

Hi. At the end of the installation, did you change the boot priority giving it to the OS you just installed? It is possible that there is still some leftover of Garuda Linux, before proceeding with the installation have you formatted the whole disk (or the empty partition you needed)? Also, it might be important to check in the UEFI BIOS that RAID mode is disabled, and, if so, set AHCI instead.

Hi, thanks for the quick reply.
So, for the boot priority I checked and it was HDD > USB > ODD > LAN, also tried swapping USB with HDD but no luck. We can boot to USB fine, but without USB after finishing install it just says no bootable device.
As for the “Garuda leftover” I’m not sure, I will post below a print of the installation menu, we selected “Erase Disk” option with swap with hibernation on, on the partition garuda was installed:

For the UEFI BIOS part, I don’t see any way to change RAID mode, can only swap from UEFI to CSM, I will show pictures of the BIOS below:

And here is system configuration:

Do you think there can be Garuda leftover as you mention the way the partitions were set up ?

Once on Calamares you select “erase disk”, it actually does for real, so there is nothing left installed.

Is it possible that GRUB has not been installed? You installed it on the root as specified by Calamares, right? Just to better understand if the OS has been installed, use Parrot in live mode (via your USB) and see if the HDD is recognized and the Parrot label appears with it. About the BIOS everything seems ok, at least try to disable the secure boot.

I am also suspecting this is some problem with grub…
We reinstalled again on a different USB drive, this time actually manually deleted all paritions with gparted and ran the installer with the “erase disk option” to clean install it from there. The system only has that HDD.
Here is an fdisk output we tried during live boot:
sda is the HDD we installed on

We can see the HDD is recognized in the file explorer but I don’t know about the Parrot label (?) is there a way to check that ?
Here is what appears on the file explorer:

Also we ran a smartctl test to see if there were any problems on the hard drive I’m sending the output in the pastebin below, but I don’t see anything wrong:

As for the BIOS, secure boot disabled still no success.
Could it really be something with grub? I though it comes with the installer and did nothing about it.

Go to bios >
Advanced > boot > boot configuration > network boot - disable.
Advanced > boot > boot priority, check to see what is listed under boot drive order.

No, at this point it is not the HDD (it can last for quite a while :)).

Then the system seems to be installed (look at the partitions, there is swap too), so it is. At this point it might be GRUB that isn’t installed, Calamares usually does unless you gave it some weird path at the beginning (like in sda instead of /). Try to reinstall it or if you want to try to restore it you can read our guide.

Just finished following the grub restoration guide you linked and still no success :(. At this point I feel like I’ve gone through everything now. The system was running Garuda fine-ish was just a bit slow due to having only 3GB of RAM, also ran lubuntu fine previous to Garuda. Doesn’t make much sense not being able to boot up now, since the HDD is fine…

@rafabro did you disable it?

When it’s enabled it first tries to boot from network
read more

We tried to find that in BIOS but didn’t see any network boot option, only have boot order available and boot mode

So, after failing everything so far we decided to clean the HDD again and install Windows to see if it was really okay and it worked “fine”. Fine in the sence that it’s alive, but very very slow do to the old system specs and low RAM, hence why we wanted to use Parrot home. Then, for the sake of it we tried to Dual Boot with the option to “Substitute Partition” on Calamares:

And now everything works, lol. Grub and Parrot boot fine… Any thoughts on this?
Ideally I wanted to have Parrot as the primary OS just to try to get the best performance possible out of the OS, but as for now it works fine.

Basically you are just dual booting
And as windows bootloader worked, grub is also placed the same way over it and hence yeah… Working!
Enjoy :smiley:
Before this did you try manual partitioning after failing through erase disk?

Yes I tried two times actually, the first one I used ext4 as filesystem and then read somewhere Parrot uses brtfs, so idk if that’s a problem? But anyway I tried a second time manually with all the recommended partitions and still no luck.
So, just to be clear this way is Windows Boot Loader being responsible for booting the system, or does Grub run before Windows Boot Loader? Because I’m struggling to understand why Parrot wouldn’t work single-handedly even after I made sure to manually install Grub as @danterolle suggested here

Parrot uses BTRFS by default, but it has little to do with it IMO. The problem here is/was with GRUB (and in fact now in dual boot you can boot it), in fact I was almost going to suggest you to use boot-repair (google it, that could be useful) for the bootloader. Because I have installed Parrot several times in a single entire hdd/ssd and I have never had similar problems, but with GRUB yes.

Once you install GRUB, it handles all the OS installed, the Windows Boot Loader is just for booting Windows.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.