Removed GRUB, Parrot installed, no boot!

Before I start, I know that a lot of responses are going to say that I am an idiot. I KNOW, and what I did was very stupid. I’m just hoping I can fix it without losing my data. Also, I admit that I am a n00b, very much so. I apologize if this request seems stupid, I’m still a student…just graduated high school.

So I have an ASUS X550Z Laptop. I installed both Windows 10 and ParrotSec OS on it and dual-booted (using GRUB) for a while. However, I bought a new windows laptop so I decided to remove the windows installation from the drive.

I booted into Parrot, opened GParted, and deleted the ~500GB Windows Partition and the Windows Recovery partition.
It worked, now Grub loaded up and shows Parrot OS and the windows bootloader. Being the stupid one, I never selected the windows option after deleting the partitions to see what it would do…

I wasn’t satisfied though…I remembered before I dual-booted (ie: when I ONLY had Parrot OS installed), it went IMMEDIATELY to the boot sequence instead of Grub. I found a forum post saying that after deleting the partitions, running update-grub should result in ONLY the linux partition showing, thus bypassing the grub screen…that sounded a bit weird to me but I was tired and just wanted to finish before bed.

I ran the command, only to see that the last line said that Windows bootloader was found on sda2 (or something like that). STUPIDLY AND OH SO STUPIDLY, I used GParted to format sda2, since all the linux lines shown after running update-grub were on different partitions. Suddenly, my bios does not see a bootable device. Following tutorials on mounting the drive while booting off a live usb and using chroot to update or install grub have not worked.

I even tried using the Boot Repair disk, but it would not help, telling me that I needed a partition with the flag ‘bios_grub’. I did save the boot info script, and it is linked here:

I am at a loss. I can boot into a live usb and copy off my files and a list of installed programs, but I would MUCH rather fix the current install.

On a much dumber note, would it just be possible to reinstall Parrot OS and copy all the files from the old /sda4 onto the new partition created by the fresh install? :grimacing:

I don’t remember the version I am running, but I just ran apt-get update on July 22, one day before this fiasco.

Thanks in advance! Love Parrot OS!

Just before starting, I’m not an expert on this, so wait until having a second opinion on the matter before doing anything here:

I want to help you, but I have a few questions:
I think you just deleted the storage partition of Windows and left the boot partition (The so-called System Reserved Partition) there so it still detected the data of Windows Bootloader In case you didn’t do it, why? I mean you wanted to leave the disk plain blank to install Parrot OS? You wanted to keep the Windows Bootloader just in case you wanted to do something with it?
Secondly, WHERE did you install GRUB? in the MBR partition of the sda device or somewhere else? As I’m reading the log, you somehow managed to delete someof the data of the sda Master Boot Record? What I’m guessing from this is that you can’t boot into ANY operating system contained in the sda decvice.
What I suggest you to do is copy any data you may want to preserve using a LIVE CD/USB (which isn’t affected because the CD/USB containing it has its own MBR partition), and either use a Live instance of parrot to reformat the WHOLE drive, or reinstall parrot selecting the ‘take whole disk’ option when asked where to install it.

Doing a quick search I found this which is a solution to a problem similar to yours for ubuntu (which is also debian based so you can try it in case you didn’t already)

Reinstall/Repair/Restore Grub with an Ubuntu live CD

I just realised you can also try to make a new partition and reinstall parrot and therefore try to reinstall GRUB in the MBR when asked to.

Repeat: im no expert

I am not sure if it works, but here is what you can try:

  1. create a live parrot usb and boot on it.

  2. When you are in open a terminal and do sudo mount /dev/sdyourparrotpartition /mnt

  3. chroot /mnt this will make make you sudo with the root of your installed system, from there you can remove programs or install almost as if your system was working and booted.

  4. run: grub-install /dev/sd"yourdisk" ones done hope for the best, if it worked type exit and then boot your system.

Trying that…running the grub-install /dev/sda4 command results in the error saying this:

“/usr/lib/grub/i386-pc/ doesn’t exist. Please specify --target or --directory”

I am looking on forums for assistance but it most of them are saying to use the boot-repair disk. Based on my previous luck with it (see OP), I might be kinda dead…

Could I just clone the entire sda4 partition to an external drive, completely wipe and re-install Parrot on my laptop, and clone the sda4 partition back in? If so, what would be your recommended program for that?

Also, I know I need to make regular backups. I hadn’t used the linux part of this laptop in a while but I plan to have it backing up to my home NAS once fixed.

Ok, tried the boot repair disk and followed the settings indicated by this page:

I followed the boot repair steps. When I ran the command to reinstall grub, it said that if I was unsure, I could install grub on multiple “devices”…I was confused, so I selected sda AND sda4 . It finished with no errors but still will not boot or show up in the boot menu. I copied the log file here:

Win 10 is up but the grub isn’t running… I don’t know if you will be able to get it back… but there is another way through win 10 settings… update and security… recovery… (tab left hand side)
Advanced start up… choose a device… that will show you the partition with your parrot os… and you should be able to boot into it…
There’s definitely many ways to get a work around… but some do not apply and just gets messy… it’s trial and error… I made a similar mistake… with gparting … well it adds flavor :smiley: as well as choice wordds… plus boot options F9 …I have been fixing my installation of win10 and parrot os… need win for abode photo shop… and steam, for quake III… good luck…

Ones you did what i told you just run : grub-install /dev/sda without number else it will not work.