Resolv.conf Configuration for dns


#1

Briefly describe your issue below:


What version of Parrot are you running? (Version 4.4, Home edition, AMDx64)

What method did you use to install Parrot? (Debian GTK )

Configured to multiboot with other systems? ( no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Looking for a way to remove my ISP dns from the equation. Adding additional dns servers doesn’t change that aqqearently. I know Parrot has its own DNS Servers, which I would not be opposed to using, but I have some of my own I like to. Either way. Any Ideas, or any additional information Needed? Thanks.


(Matt) #2

So using specific DNS servers for portable devices can cause problems, as mentioned here: Static DNS Parrot OS. But for desktops on your own network you shouldnt have any issues.

sudo rm /etc/resolv.conf removes symbolic link
sudo cp /etc/resolv.conf.head /etc/resolv.conf sets the parrot servers as the only DNS

You can add your own servers by adding nameserver <IP> into /etc/resolv.conf.

If it causes problems you can re-create the symbolic link using:
sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf


#3

┌─[[email protected]]─[~]
└──╼ $sudo rm /etc/resolv.conf
[sudo] password for x15test:
rm: cannot remove ‘/etc/resolv.conf’: No such file or directory
┌─[✗]─[[email protected]]─[~]
└──╼ $

Typical terminal reply for me.


(Matt) #4

hhmmm ok…

Doesn’t matter anyway, just carry on and do sudo cp /etc/resolv.conf.head /etc/resolv.conf.


#5

┌─[[email protected]]─[~]
└──╼ $sudo cp /etc/resolv.conf.head /etc/resolv.conf
[sudo] password for x15test:
┌─[[email protected]]─[~]
└──╼ $

Left me with flashing command prompt. According to the network manager applet, my dns is the same, disabled and re-enabled.
Come to find out, it screwed up my internet connection. it showed connected, but neither my browser or email client could connect. used"sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf" and it repaired the connection.


(bow to the cow.. m00) #6

Launch anonsurf


#7

Start Anonsurf:

Gtk-Message: 19:09:56:646: Failed to load module “atk-bridge”

continued with housekeeping and closing dangerous apps, Anonserf said “connected”, but had no internet access, even though network manager said I did. Shut down Anonsurf, same error message, but internet connection restored.


(Matt) #8

When you have that blinking cursor, its usually when you should enter your password.

Maybe you isp is blocking external dns servers.


#9

I’m pretty sure my ISP isn’t blocking, I’ve been using alternate dns servers for several years on this computer, different os. I ran the terminal again, sudo rm /etc/resolv.conf blinking cursor, typed in password, bash, no such command. So I ran sudo rm /etc/resolv.conf again, and got “no such file”, so I assume I removed it the first time. I ran the rest of it, and checked it with sudo nano /etc/resolv.conf. Only Parrot Dns in there. so I restarted my wifi, Reconnected, still showing this


Network manager still showing my router as all the dns. This router is not from my ISP. I bought my own, and put it between me and the ISP modem. Anyway I looked in the /ect/ folder, and I had a ‘resolve.conf’, ‘resolve.conf.’, ‘resolve.conf.head’, ‘resolve.conf.save’, and a ‘resolve.conf.save.1’. I deleted everything but the ‘resolve.conf’, and started over. ran through the commands, now have ‘resolve.conf’ and ‘resolve.conf.head’ with only Parrot dns on it. Wifi manager still showing Router IP as default. One question, ect/resolve.confl/resolve.conf.d/head, has no information on it. Should it have the Parrot DNS on it also?


(Matt) #10

What application is giving you that information? i cant seem to find it myself.

Dont worry about anything in /etc/resolvconf/ thats for the daemon. So no the head file doesnt need anything in it.

Might be worth opening wireshark, selecting your interface, then searching “dns” in the top search bar. Then if you browse to a few sites, wireshark will output where it is sending the DNS queries. As that application you are using might be a false positive.


#11

Ok, I’ll work up wireshark. Thanks for your time.


(bozkurt) #12

I always need to change /etc/resolv.conf 's nameserver to 8.8.8.8 becuase everytime it boots, it comes back to 192.168.1.2 and its not working of course. how can I fix it, how can I immobilise it?


#13

Well, according to Wireshark, I’m definately using Parrot dns. I can’t find anything from my isp, but holy cow, what a lot of communication in such a short period of time. Anyone know a way to lookup a load of IP address without getting banned from the lookup site? I’m also getting a whole lot of ‘acks’, but I guess thats better than connections. I’m only using UFW, but I’m about ready to attempt to configure iptables again. Thanks for the help! And to mrbozkurt, I haven’t rebooted yet, we’ll see if it holds.


(Nico Paul) #14

what exactly are you trying to accomplish or prevent?


#15

I’m trying to prevent my computer from using my ISP’s DNS servers. My ISP is a very large multi-national company. They sold our email to another very large multi-national company, and offer no real customer support. Anything I can do, including changing email services and dns services, that will give them a little less information to scavage and sell, makes me happy.


(Matt) #16

After the symbolic link has been removed it will be persistent across boot.

@mrbozkurt
If you follow the steps in my first reply, you will make it persistent. You will have to add googles DNS to resolv.conf though, if you want to use it.

Create your own thread if you need further help.


(Nico Paul) #17

i believe it is already his haha someone may be a tad sleepy haha #metoo #ugh #zzzzz


(Matt) #18

The last bit is at ‘mrbozkurt’ you silly sausage.
Is it not 4am for you… please get some sleep :sleeping:


(Nico Paul) #19

I formally abstain from all further communication for this morning. haha yeah you would think I would have adjusted to working during the dead hours by now but for some reason I have not. I do however have two completely refinished bathrooms that this guy learned how to do ALL BY MYSELF! Ordinarily Im alright with stuff like that but nowhere near as acceptably decent as they actually turned out honestly. Im waiting for spackle to dry and pray that i dont get too many crazy calls and then get to a point I can go sleep sleep haha


(bozkurt) #20

I don’t sleep at nights. I sleep in silly lessons because I have to attend courses more than %80 in total. Such a waste of time. By the way, resolv…conf returning its original form after I boot OS again.