ricochet-im won't open

I am trying to start ricochet-im. But it won’t work. When I try to start it from the GUI nothing happends.

┌─[root@rivendel]─[~]
└──╼ #which ricochet
/usr/bin/ricochet
┌─[root@rivendel]─[~]
└──╼ #which ricochet-im
┌─[✗]─[root@rivendel]─[~]
└──╼ #where-is ricochet-im
-bash: where-is: command not found
┌─[✗]─[root@rivendel]─[~]
└──╼ #whereis ricochet-im
ricochet-im:
┌─[root@rivendel]─[~]
└──╼ #locate ricochet-im
/usr/share/applications/ricochet-im.desktop
/usr/share/doc/ricochet-im
/usr/share/doc/ricochet-im/changelog.Debian.amd64.gz
/usr/share/doc/ricochet-im/changelog.Debian.gz
/usr/share/doc/ricochet-im/copyright
/usr/share/doc/ricochet-im/doc
/usr/share/doc/ricochet-im/doc/deprecated
/usr/share/doc/ricochet-im/doc/design.md.gz
/usr/share/doc/ricochet-im/doc/protocol.md.gz
/usr/share/doc/ricochet-im/doc/deprecated/protocol-1.0.txt.gz
/var/lib/dpkg/info/ricochet-im.conffiles
/var/lib/dpkg/info/ricochet-im.list
/var/lib/dpkg/info/ricochet-im.md5sums
/var/lib/dpkg/info/ricochet-im.postinst
/var/lib/dpkg/info/ricochet-im.postrm
┌─[root@rivendel]─[~]
└──╼ #ricochet-im
-bash: ricochet-im: command not found

You are running it wrong

ricochet 

(ricochet:128803): Gtk-WARNING **: 06:10:18.261: Failed to parse /home/dmknght/.config/gtk-3.0/settings.ini: Permission denied
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
/usr/include/c++/9/bits/move.h:194:7: runtime error: load of value 279, which is not a valid value for type 'Type'

This is error of the application.

Ok so far I found my mistake. But I still can’t get Ricochet-IM to start?

┌─[✗]─[androgion@rivendel]─[~]
└──╼ $ricochet

(ricochet:22857): Gtk-WARNING **: 07:44:26.406: Failed to parse /home/androgion/.config/gtk-3.0/settings.ini: Permission denied
Qt: Session management error: None of the authentication protocols specified are supported
/usr/include/c++/9/bits/move.h:194:7: runtime error: load of value 279, which is not a valid value for type ‘Type’
┌─[✗]─[androgion@rivendel]─[~]
└──╼ $sudo ricochet
[sudo] password for androgion:
No protocol specified
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

I can duplicate your issue. I additionally installed qt5dxcb-plugin.

┌─[✗]─[a-man@parrot]─[~]
└──╼ $ricochet
(ricochet:13027): Gtk-WARNING **: 02:54:14.377: Failed to parse /home/a-man/.config/gtk-3.0/settings.ini: Permission denied
Qt: Session management error: None of the authentication protocols specified are supported
/usr/include/c++/9/bits/move.h:194:7: runtime error: load of value 279, which is not a valid value for type ‘Type’
┌─[✗]─[a-man@parrot]─[~]
└──╼ $sudo ricochet
[sudo] password for a-man:
No protocol specified
No protocol specified
qt.qpa.xcb: could not connect to display :0
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
Segmentation fault

This is more of a ricochet issue. It may have something to do with using the wayland protocol.

A QT app trying to get config of gtk-3.0? it is weird.
And it is bug of this app anyway. Could be from latest version.
Wait for new update is only way to use it.

That seems like it… than I just have to be a bit more patient…

Glad im not the only one having this issue. Pulled my hair out trying to fix/update around all errors. I dont know how we can wait for an update when the site says the latest is 2016. Is there an alternative to this chat or is it toast at this point?

You can always use Pidgin with pidgin-otr (Off The Record).

OTR allows you to have private conversations over IM by providing:

  • Encryption
    • No one else can read your instant messages.
  • Authentication
    • You are assured the correspondent is who you think it is.
  • Deniability
    • The messages you send do not have digital signatures that are checkable by a third party. Anyone can forge messages after a conversation to make them look like they came from you. However, during a conversation, your correspondent is assured the messages they see are authentic and unmodified.
  • Perfect forward secrecy
    • If you lose control of your private keys, no previous conversation is compromised.

This is a Pidgin plugin which implements Off-the-Record (OTR) Messaging.

Hoping for the best?

I am delving in an alternative… but not yet sure what it will be

Edward Snowden uses Signal.

  1. Install our official public software signing key
    wget -O- https://updates.signal.org/desktop/apt/keys.asc | sudo apt-key add -
  2. Add our repository to your list of repositories
    echo “deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main” | sudo tee -a /etc/apt/sources.list.d/signal-xenial.list
  3. Update your package database and install signal
    sudo apt update && sudo apt install signal-desktop

I’d recommend signal as well. The client is smooth compares to wire (and i am a fan of wire to be honest).