seclist_2021.4-0parrot1_all.deb fails checksum test

ISO: Parrot-security-4.11.3_amd64.iso
Installed: VMware Workstation 16.2.1 with Windows 10 host
Apt Method: Synaptic

I installed Parrot today, and used sudo parrot-upgrade to upgrade base packages and rebooted. I then launched Synaptic to install additional packages. I have tried numerous mirrors to attempt installing seclist. It downloads, but then complains about SHA-256, etc. checksum failing and doesn’t install. In between using each mirror, I run

sudo apt clean

to remove cached packages in order to attempt downloading and installing from each mirror.

I ended up using a web browser to download the package and installed it via GDebi.

Just a head’s up.

Maybe some mirrors have / had sync problem. I’ve just tried install sectlists and everything is fine here :smiley:

1 Like

I’m now having issues with greenbone-feed-sync. This all could be related to me disabling side-channel mitigations for Hyper-V enabled hosts in VMware. I’m going to disable things on the host that allows me to use WSL2 and reboot to see if it makes a difference.

    183,293,080  51%  646.31kB/s    0:04:30  
unexpected tag 95 [receiver/inc]
rsync error: error in rsync protocol data stream (code 12) at io.c(1648) [receiver=3.2.3]
rsync: connection unexpectedly closed (1524 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(228) [generator=3.2.3]

I’m afraid greenbone / gvm / openvas is something we are not really maintaining right now. I mean it looks like data syncing is having problem, and maybe our version is kinda old for latest database format (maybe). I want to give it an update but it has too many source packages and I have no experiences on maintaining this package.

Greenbone Vulnerability Manager has always been a pain to setup on Parrot, but I got it working on a few different installs in the past 2 years.

I removed all the WSL/HyperV stuff on Windows 10 and rebooted. The latest VMware’s “disable side-channel mitigations for Hyper-V enabled hosts” is no longer an option for guests with those things removed. Despite purging GSM and removing the feeds before reinstalling all the GSM packages, I still get failed verification on certain downloading feeds.

WARNING: --*.xml failed verification – update discarded (will try again)

After using Parrot Security (Mate, KDE Plasma, XFCE) bare metal for around 6 months as my daily driver, my need for Windows freeware tools overcame my dedication to staying with Linux.

VMware (for Linux) and VirtualBox on Parrot ran Windows 7, 10, 2016 Server really slow and XP was barely acceptable (Linux distros ran fine in VMware though).

I finally gave in and am dual-booting Windows 10 and Kali. I’m upset that Parrot as a VMware guest is having issues, whereas 6+ months ago it ran fine on Windows 10 for over a year and a half. This is probably due to the latest VMware Workstation 16.2.1 update.

Oh LoL thanks to remind me that. I remember it now haha.

Well I personally have problem with VMware. Parrot inside VMware is extremely lag. It is not only Parrot’s problem because I did quick search on google and i saw complains from ubuntu and other distro as well. For now vritualbox is having wrong dkms version (damn… Palinuro) and I have to switch to virtmanager. It works smooth, but i prefer features of VMWare. More about problem of VMWare: Parrot has been laggy for me but in latest update, it was like unusable.

1 Like

It looks like the cheap ($13 at the time, now $25 on Amazon) Panda Wireless PAU06 USB Adapter I bought for using monitor mode which worked well in Parrot and Kali doesn’t do so well in Windows, randomly dropping connections when downloading.

My older NETGEAR WNA3100 N300 Wireless USB Adapter which didn’t work at all in Linux works well (but slower) in Windows.

PS: After ~4 hours of Googling Hell and a lot of frustrating work, I got Greenbone Vulnerability Manager working early this morning on bare-metal Kali, scanning my new wireless router (and finding no exploits).

I had to manually create new directories and empty files using various permissions among other tricks for Redis and GVM to work together. It was NOT this easy even on a fresh Kali install…

That is a heck of too much work. Well I have to try gvm inside the vm again to see how it goes

1 Like

@Masmer tested in virtmanager, no problems with gvm-setup. I’m running the gvm-check-setup to see if there is anything wrong.
I think your problem with rsync was about network connection.

I think my initial problem with seclist, and then the problem with GVM feeds, was due to my Panda Wireless PAU06 USB Adapter using Windows and VMware using NAT.

I’ll try using the PAU06 directly in VMware (via removable devices) with my Parrot guest to see if that is stable.

Sorry about reporting an issue without fully checking possible causes first. I just thought seclist was having an issue downloading at first.

I tried using virtmanager with KVM a couple months ago on my second tower PC running Garuda Linux Blackarch Edition and didn’t quite know how to do things compared to VMware/VirtualBox. I’ve watched a few more YouTube videos on virtmanager (shared folders, using hardware directly, etc.) since then and will eventually investigate setting it up.

Thanks for all you do @dmknght!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.