[SOLVED] Android device with ADB error


(Yoav) #1

Briefly describe your issue below:

Hi, I am trying to connect an Android device in USB Debugging mode to my Parrot OS computer. When I try to see which devices are connect with the command:
adb devices

I get the following error message:

08a8668302221fc1 no permissions (user in plugdev group; are your udev rules wrong?); see [http://developer.android.com/tools/device.html]

I tried to follow the suggested link but there was nothing there which was relevant.
I am not too familiar with udev rules… I am assuming that Parrot restricts some of the access to USB for security reasons, but I am not sure what it is I need to change in order to get past this error.

What version of Parrot are you running? (include version, edition, and architecture)
Parrot OS 4.5.1 Home edition, AMD64, all updates performed.

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK, no issues with installation or booting.

Configured to multiboot with other systems? (yes / no)
yes, with Windows 10, works well.

If there are any similar issues or solutions, link to them below:
Nothing I could find - searched for the term “adb” but nothing came up.


#2

In order to use ADB you must have adb package from the package manager, enable developer mode on on the android devices and enable usb debugging in the developer options menu. You shouldn’t have to touch the udev rules.


(vladislav) #3

Have you tried running this with sudo?


(Yoav) #4

I do have all the things mentioned in place. I did find a solution, will respond below. Thank you for replying!


(Yoav) #5

No I have not! (I guess I should have thought of that myself!).
I did find a different solution.


(Yoav) #6

Hi all.
I ended up finding a solution on StackOverflow:

For some reason, just changing (on the phone) the USB mode from “debug mode” to a “file transfer mode” did the trick.


closed #7