[Solved] Parrot 4.5 does not shutdown

Briefly describe your issue below:
Hello guys,
I have dell g3 3579. The problem is that I cannot shutdown or reboot my system.
When I boot my system I see some acpi errors but the system works fine. I can boot navigate do what ever I want. just when I want to shutdown the system just hungs and it freezes there for ever.
I tried adding acpi=off and acpi_osi=“Linux-Dell-Video” as mentioned in https://doc.ubuntu-fr.org/dell_g3_3779
but no luck… tried also poweroff -h and other stuff nothing seemed to work. I tried kernel version 4.20 and 4.18 and nothing also. I tried MXLinux and I faced the same problem and the support there doesn’t seem to be able to solve the problem.
I have multiboot with the “spyware windows 10” .
I installed the system multiple times and the same problem persisted. What made me frustrated is that the GTK installer when installing the system is able to reboot and when starting the installer the acpi messages does not show in the screen.
(one weird thing to add also is that when I try to install backbox 5.2 after selecting install backbox in the grub menu I get into a ubuntu recovery session maybe this is due to the recovery partition in the harddrive, I don’t think this is relevant to the problem but I should mention that) .


What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Commands you can use are: ‘reboot -f’ , ‘halt’ , ‘poweroff’, ‘shutdown -h now’. Please try those commands, and lets see results. For mor infos please join #parrotsec channel onirc.freenode.net

same problem. I get the mouse cursor disappeared and the system is frozen.
I think it is a bios problem.
I checked dell website I found bios updates. Maybe I should update the bios version to correct acpi problem…
Is that risky ?

what if you run the live iso, can you reboot using that method ? instead of your hdd install

Hello thanks for you reply,
The live mode works perfectly good. when I select live mode I do not see the acpi messages everything is good (desktop wifi …) and reboot also no problem.
but after installing acpi messages + can’t reboot / shutdown

Now in the grub menu I changed the boot options from “quite splash ro noautomount” to the parameters just like the live boot which are “splash noautomount apparmor=0”
the acpi errors disappeared but the problem was not solved; I coud not shutdown/reboot same problem persist.


1 Like

worked perfectly thank you very much Amzker. acpi error messages are still there but my system is able to shutdown and reboot.
Could you please tell me if I should expect any disabled features or services?

1 Like

Sorry But i not know​:disappointed_relieved::roll_eyes::roll_eyes:
Boot in older kernel

1 Like


I found 2 solutions that worked for me (think-pad t460).

Go to BIOS and disable SECURITY CHIP.


Downgrade your kernel version (5.13.0 worked fine on my case). You can have multiple kernels installed, so it is also a viable option in case of the security chip didn’t work.