Some Bugs in Parrot OS

Briefly describe your issue below:

1.When I suspend my Notebook and want to unlock it its not possible to do it sometimes. It happens too many times and each time i must hard reset the notebook because no key combination works(the mouse dont works to). The only thing I can see is that its typing characters into the passwort field and than the notebook hang up.

2.The Brightness and Volume Icons in Mate are a little bit buggy. They are only buggy when i use the FN+ F5/F6 / F10/F11/F12 key combinations. I will try to reproduce it and upload a video or a picture of it.

3.When i change the brightness with the icon in the upper mate panel its getting darker after maybe 10 seconds.

4.It should be possible to remove noscript easily.

Update 12.09.2019

5.When I press Win/Super + T the Terminal is opening twice
I had this Issue on my Desktop PC a few months ago. I think it came with the 4.7 Update

6.When I Login and change immediatly the brightness with the brightness Icon the system beginn to stuck and sometimes hang up. If its dont hang up 2 Electron apps beginn to flicker.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/Linux
Security - Mate

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

I think it was Debian GTK

Configured to multiboot with other systems? (yes / no)


If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

  1. Same happens here. Laptop goes to deep sleep mode when i close lid for long time. Then i have to forcefully reboot the system.
  2. Can’t help. Describe the Notebook’s model number.
  3. Right click battery icon > Preferences > On Battery Power >
    • Uncheck Dim display when idle
    • Uncheck Reduce backlight brightness
    • Set display timing to 10 minutes
  4. haven’t tried it. Can’t help

I have noticed that since the last “big” update, the shutdown is considerably slower ( average of nearly 3-4 min) after selecting shutdown from the menu with nothing else visibly running. I have also tried sudo shutdown now from the cli, which still takes 2-3 min to shutdown.

Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/Linux running MATE

I was waiting for a “mostly all clear” on the beta to try an upgrade.

Have you installed graphics drivers?

Thanks, we will appreciate it. Though does it happen only on Mate? We will try to reproduce it.

What do you mean?

Check your DE shortcuts, probably there is missconfiguration somewhere

That is mostly probably because of how many times the brightness applet slider accesses backlight control file, have you searched the web if someone has similar problems?


Please check your logs, … my PC in the office has the teredo interface which i don’t know what the hell is it and why the duck it is here. Sometime that interface makes my machine wait 1m30s to shut it down. I don’t think this is common problem. It must have something like error logs or debug logs to figure it out.

FYI - there is some interesting info on Teredo here: Teredo tunneling

However, if I read it correctly the version for Linux would be Miredo
Miredo [1] is a Teredo tunneling client designed to allow full IPv6 connectivity to computer systems which are on the IPv4-based Internet but which have no direct native connection to an IPv6 network.

Miredo is included in many Linux[2][3] and BSD[4][5] distributions and is also available for recent versions of Mac OS X.[6] (Discontinued)

It includes working implementations of:

  • a Teredo client
  • a Teredo relay
  • a Teredo server

I will have to dig more into logs to find what my issue with shutdown is caused by.

nah it is teredo on my pc and i don’t know why the hell it is there but it is okay for me.
p/s: do you have any msg log during system shutting down?

no, no messages and I have found no reason or error in the logs yet

After hitting google a bit, seems there have been issues reported regarding hibernate (which I saw someone else here posted problems with) and shutdown (though most seem to involve the 4.9 Kernel). The reports seem to indicate that this is a problem in systemd and/or the kernel, but at least one other source points to ACPI in some systems

1.It seems to be installed. Same problem after 4.7 release but without random characters. After it wake up its not possible to use the internal mousepad and keyboard. Im forced to use external device to login and reboot. I will try to save the log next time.

2.not fixed

4.I cant uninstall noscript over the addons settings. I was forced to delete it in the firefox directory.

5.It only happend when I used win + T. Couldnt find any missconfiguration so I will use alt + t.

6.seems to be fixed

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.