Source list -Certificate verification failed

Hi All,
I wanted to update Parrot packages, when I was trying to do this I received info:

Err:1 rolling/main amd64 netselect amd64 0.3.ds1-28+b1
Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate. Could not handshake: Error in the certificate verification. [IP: 443]

I cannot install anything so upgrade certificate (via apt…) is not possible.
I’ve tried to change from https to http - does not work.

My source list is as follows (parrot.list):
deb rolling main contrib non-free
deb rolling-security main contrib non-free

Strange thing that in the error message is and I cannot find how to avoid situation to look at local mirror.

Parrot version:
Linux parrot 5.5.0-1parrot1-amd64 #1 SMP Parrot 5.5.17-1parrot1 (2020-04-25) x86_64 GNU/Linux

What method did you use to install Parrot?** Parrot Security KDE ISO

**Configured to multiboot with other systems?NO

Thanks for any tip.

well, I do have same thing, though it is not a major issue. You can either try manually installing the certificates or leave as it is. In future updates, it may be fixed

I have had the same problem today and in the past. Also cannot connect to community, I get a 503 error, when this happens.
Solved by running dnstool, then disconncting. Take the dogs for a walk, reconnect and everything is fine. I put it down to me doing something stupid as try as I might I cannot reproduce this situation if I try.
bing was down for a bit yesterday…
this often happens for a little while on days that a major update rolls out.
when i receive these errors, i do exactly what you did. Walk the dog. (Smiling like it’s Christmas and wondering what cool new stuff Lorenzo has for me) :wink:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.