SQLite3 will not install - broken dependencies

after latest update to Parrot v4.9 yesterday - my SQLite3 is broken - seems that SQLite package is looking for an older dependency than is installed for libsqlite3-0 :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sqlite3 : Depends: libsqlite3-0 (= 3.31.1-5) but 3.32.2-2 is to be installed
E: Unable to correct problems, you have held broken packages.

How exactly has this happened and more to the point - how can I get SQLite3 installed - I need it for all manor of base development work?

1 Like

Happens all the time after a major update it takes time but the dependencies will be fixed

For now use sqlitebrowser

ahh ok - never noticed it before…knida strange that the dependencies get muddled like that…But thanks for heads-up :slight_smile:

Tried apt install -f ?
ps. from which version were you upgrading?

Thanks Irene - bu that does not seem to help any…
I cannot tell you which version I had before as it has been deinstalled…:confused:
Hence my problem - model db schemas in SQLite first a lot and use the cli/vim and it’s real fast - but for now I cannot.
I am not sure - as I do not like the idea of “just wait and it will come along” - I am not sure what is the process here - Are these pure Debian packages? If so, why does it not work as SQLite is running on my Debian Buster 10 workstation fine.

A Rolling Distribution Means it is Built/Based on Debian “bullseye” also Know as Debian Testing
as Most packages are built/based for/on Debian Stable ,thus there are Dependency issues for Rolling Distributions

more information below
Debian Releases

me too i’m facing this problem it take time to fix it

When will this issue fix ?

I understand that…However …this dependency is a SQLite package too…I could understand a huge app with thousands of external dependencies monster…But this is only two packages.

SQLIte and libsqlite3 - these two should almost be bound together in single pacakge anyway…So SQLite package is up to date and the libsqlite package is not - It suggests to be that something in the Parrot distro package list of out of kilter? Again - I do not understand how those two pacakges could get out or alignment…Unless maybe for about 10 minutes or so during a release…

On my pure Debian box it upgrades to latest version with correct libsqlite3.


ps - yes that is Debian Testing - I have always used that and it is pretty stable…

1 Like

Good question - I still do not understand how it can even be broken?

So question to “Magical Parrot Keepers” - Any pointers on what is actually going on here and how long it will take till it “just works” again…?? It’s been about a week already…

1 Like

I installed it manually and worked well you can try it

ok thanks Zero1 - What does “installed it manually” actually mean - because “apt-get install -y sqlite3” is also manual :wink:

Seriously as i need to get this tiny little tool installed …

1 Like

I mean donwload it from https://www.sqlite.org/download.html :wink:

Hi there, Anyone can link me to the steps that needed to be taken.

These are the steps I used install manually, using direct download of deb files.
This may not be an ideal solution, but it may help anyone who is stuck and just needs to get sqlite3 working.
Be aware that versions shown are the latest at the time of writing, but newer versions may have been release.

  1. Download latest libsqlite from debian.org.
    wget http://ftp.us.debian.org/debian/pool/main/s/sqlite3/libsqlite3-0_3.32.3-1_amd64.deb
  2. Download latest sqlite3 from debian.org.
    wget http://ftp.us.debian.org/debian/pool/main/s/sqlite3/sqlite3_3.32.3-1_amd64.deb
  3. Install libsqlite3-0
    dpkg -i libsqlite3-0_3.32.3-1_amd64.deb
  4. Install sqlite3
    dpkg -i sqlite3_3.32.3-1_amd64.deb

Thanks @durkinza - that’s good to know…
BUT - I still do not understand how on the Parrot distro SQLite STILL does not install. SQLite is so core to to so many things…I am still getting the same message as a month ago (which belies the far tthat “the distro will simply catch up with packages…” - not true!

 The following packages have unmet dependencies:
 sqlite3 : Depends: libsqlite3-0 (= 3.31.1-5) but 3.32.3-1 is to be installed
E: Unable to correct problems, you have held broken packages.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.