Stuck on login,black screen ;/

Briefly describe your issue below:
hi all
i have been trying to get parrot to work on my new alienware (
and i can get it to do a successful boot. i installed the os, grub works fine and so does windows HOWEVER, i go to log on and i get a black screen with disfigured black text and then the login screen again! i can use the text version but that’s it…any help would be appreciated.

I am runnin

What method did you use to install Parrot? iso, via usb

Configured to multiboot with other systems? (yes / no) Yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Many people have had luck pressing ctrl-alt-F1 and then ctrl-alt-F4 or F7 to go from the GUI to command line and back which sometimes seems to fix the disconnect (whatever is the true issue anyway) but I have had to log in via TTY (just the first ctrl-alt-F1) and then type reboot to reboot the system. I’ve just gotten in the habit of either being ok redoing what I was typing if I’m lesving my rig (so much awesome practice though) or being more mindful of suspending/hibernating.

that still does not seem to be working for me ;/

Have you tried the startx command? What is the output? Did you try and configure any graphics drivers? Can you post the output of lspci | grep OpenGL/VGA/optirun (switch out the last word in order to display 3 outputs total) *notice | is not L (l) or I (i) but the symbol.

Im getting the same error.

So here is my result of lspci | grep VGA, the Rest didn’t output anything:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family integrated Graphics Controller (rev 09)

startx (i didnt want to type it off) :

Used System: hp elitebook 8640p
Cpu: i5 2540M
Ram: 16gb DDR3
Dual Boot yes with Windows
Installation via iso/usb

I’m having same issue. Some searching and trial/error suggests that it’s an issue with the kernel version. Parrot20 = black screen whilst parrot10 works fine. To get around this I’ve just given up and am using old kernal version but any ideas on when 4:19 will be rolled out and even if this will fix the issue with integrated graphics??

I had the same issue, something to do with integrated graphics and the new kernel

Just checking in to confirm that this is indeed a problem. All of my current laptops (older Dells) need to be on parrot10 to function. Intel Integrated graphics chips and parrot20 do not work.

Hi lads,

I can only guess its eufi bios try booting in legacy mode in settings, mate inviroments seem to have a problem with eufi.

Sadly not, grub boots fine but nothing more after selecting parrot20-amd64 kernel.

One of the Dell laptops that’s been upgraded to the new kernel doesn’t even have an option for uefi boot and still boots to a black screen, so that’s definitely not the problem.

Try going into bios then making parrot os the first boot device…I know it sounds stupid but give it a try.

I am using an old Lenovo Thinkpad T410 (not dual booting) and the same has happened to me. The display does not come up after grub does its thing if left to default. I could only get access using the older parrot10 kernel.

I decided to try Kali which installed fine, but after a subsequent update / full-upgrade, which included an updated kernel, it too would not display anything after the grub screen. Again access could only be gained using the advanced grub option and selecting the previous kernel.

Seems like the new kernel these distros are using doesn’t like on-board Intel HD Graphics in older laptops…

1 Like