Sugestion ALL rtl-8812au & rtl-8814au TRY rtl8188eus Driver

Hello guys and gals,

I want to give briefly my experience with ALFA AWUS-AC1200/AC-1900 = rtl-8812au & rtl-8814au Drivers

All over the web, Kali, Ubuntu, Arch, Debian, you name it, Millions have struggled with this Driver from Aircrack-ng/rtl-88xxau or in the repos.

I just got a sweet new Laptop for free, its a HP(whatever thats irrevelant) but its a decent I3 with a NVMe and 8Gigs of DDR5… No GPU only Intel but again, thats irrevelant. If you got a serious rig at home thats for heavy lifting.

Your Laptop needs to have the wifi drivers installed, properly, and so your tools can use the adapter. To do this all of the guides and tutorials that ive seen, and even Aircrack Team themselfs fail at delivering a way to get your New ALFA adapters working and I hope Telling you to try the OTHER Aircrack-ng Repo labeled rtl-8821xx.

For what ever reason the drivers designed for stock wifi that comes with new Laptops like HP, Dell, Lenovo and maybe Mac too compleatly fixed my ALFA AC1900 issues, and not only that, but also got my internal PCI-E wifi which is the rtl-8821ce now can monitor and packet inject along with the Bluetooth can do all kinds of michief too.

I had no idea my new laptop by HP was built for pwning wifi & bluetooth LOL. So I havent seen anyone recommened to use the Repo “they dont tell you about” on Aircrack-ng’s Github. But 3 weeks of trying every way I could find didnt work. Either Bettercap cant turn the power TX level on, or Wifite2 goes into Monitor Mode and dosent even see the Network your currently connected to. So the Thousand other things that are broken from using the Drivers that would make sence to use and are advised to use, didnt work for me. But blindly Discovering this Alternative repo on Aircracks github the rtl8188eus, it has MANY adapters in that Repo, none of mine are in thier, however now everything works as if Linux, HP, the Aircrack-ng Team, and Lets Not Forget are Most Respected Jedi Master “Master Palinuro” collaborated to build me an amazing mobile radio pwning platform.

I can now run for example, 3 Seperate MITM’s and a 4th Bluetooth Audit of some kind, as well as my HackRF intercepting WHATEVER GSM LTE CDMA Audits. Or 2 Adapters are just getting 4way Handshakes, sending the hashes to my Server at home thats easilly cracking them with my Nvidia GPU. All automated while I’m actively engaged in a Bettercap Social Engineering Audit using Beef PLugins. And you can setup wiggle with (even tho its for Rpi) Pwnagotchi on a Laptop, with a 10$ Pi ZERO and Drive around Wardriving, Warwalking, War-whatevering letting the Pwnagotchi AI come up with its own Divide and Conquer Stragety lulz…

Also I want to mention, the rtl8188eus solved all my Pi-Zero problems with Monitor on wifi using AC1900 Adapter’s rtl-8814au too. Just make sure you do the extra compiling steps for Rpi which I cant remember exactly but you compile kernel headers specific to RasberryOS. So if you want to try the “other” Aircrack-ng Repo I just ran the uninstall-dkms-rtlxxxx, rebooted, installed rtl8188eus using sudo ./dkms-install.sh, then second reboot. and to my surprise every adapter for wifi bluetooth and my LTE 4G modem all worked perfectly.

Give it a try, color outside the lines every now and then, and Good Luck!!

1 Like