Symbol grub_file_filters not found while installin

Briefly describe your issue below:
Well first of all I must tell that im new here and doesnt have a big idea about parrot os.So for the first time I tried to install this OS to learn ethical hacking and etc.I created a bootable pendive using rufus and plugged it into my laptop which had windows 10.Then I went to the boot menu and booted with the bootable pendrive.A screen l loaded.Then I choosed GTK INSTALL. But nothing happend but directed me the error symbol grub_file_filters not found.Then I tried also other options any of them didnt work but directed the same error.
(I offed secure boot,offed fast boot resetted bios any didnt work)
But when I tried using it in my computer with windows 8.1 it worked well.Also I noted that in my laptop(in which parrot os didnt work the parrot os boot menu was different.


PLEASE SOME ONE HELO ME TO FIX THIS ERROR symbol grub_file_filters not found

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)Parrot Security 4.7

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Couldnt install But tried all methods

Configured to multiboot with other systems? (yes / no)yes

**If there are any similar issues or solutions, link to them below:**Hmm there are some simmilar errors but they are not occured when installing

If there are any error messages or relevant logs, post below

Please read our doc before install.

1 Like

I read the doc and also followed a youtube video but any of these didnt work :frowning:
Please Help!
Gets the same error .

Try with another periphery. Maybe buy a CD and mount the iso file through windows on that, then try again. It could possibly work. I had a lot of problems installing parrot in the pc I’m typing you from. Just try every possible method.

Thanks for the support I will try

Hi !

Sadly I don’t think using another peripheral will help anyone with this issue. I am having the same right now.
I installed a lot of different debian based systems with the usb key I am using, and it always worked just fine (ParrotOS included). on top of that I haven’t ever seen this error message on any forum before, and suddenly I see people with this exact one on telegram, the forum, and me?

I think the Parrot Team messed up with the iso file on the last update. My theory is that they uploaded the virtual machine version instead or something like that? because when googling “grub_file_filers” I only find Virtual Machine related issues.

I hope this issue is resolved soon !

My bad !

When writing to the usb stick, you have to use DD mode with RUFUS. I should have read the Documentation

DD is something for linux but you can use the software parrot recommends and try your luck(my pen was broken when i used it)

GOOD NEWS!
I solved my problem by using etcher with a new pen!

I have the same problem with grub_file_filters not found, solved with 2 options, 1st one, i did it with Etcher with the same usb stick BUT… ! With different usb port, 'cause etcher returned me an error with no possibility to write on my usb stick from first usb port.

Good luck for your try and thanks to this post and people who participated to helped me to solve my problem with parrot.

Hello . Just write the iso in DD image mode. This worked for me.

So I also faced the same issue and I would definitely suggest using dd, its your best bet.

1 Like

i am also having same trouble… can someone please help me out!

If you have used rufus try using etcher. It’s the thing gave good results for me.

If you get this error on UEFI - booting from a FAT32 partition , it is because the grub2 version used does not understand the FAT32 filesystem that the linux files are now on.

To fix this, extract all the files from a Ubuntu x64 ISO’s \EFI\BOOT folder and overwrite the files in the \EFI\BOOT folder of the FAT32 partition.

If you also want UEFI32 boot to work, repeat this using a Ubuntu or similar 32-bit ISO and copy the *.efi files over.

The MBR\Legacy version of grub2 in Parrot OS ISO does support FAT partitions, but the EFI grub2 version of grub2 has been cut down to the bare minimum!

DD On rufus works

First, Rufus for flashing any Linux distro is not good. In particular, for flashing ParrotOS can cause error like this.
use BalenaEtcher for flashing Parrot and anyoother Linux distro.