System freezing while in browser

Briefly describe your issue below:
I’m having an issue with the system completely freezing while using the browser with the latest update.this didn’t seem to be an issue with prior updates.
just curious if they’re any possible fixes for this,or if this seems to be an issue for any other users?
it seems i’m having to reboot the system on just about every attempt after just some very lite browsing…
any help is appreciated.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Parrot Home MATE ISO 4.9
Release 4.9 64-bit
Kernel Linux 5.6.0-2parrot1-amd64 x86_64
MATE 1.24.0

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian standard

Configured to multiboot with other systems? (yes / no)
No

List your hardware specs to include make, model and firmware (when applicable):

product: HP Notebook (M2C60UA#ABA) 64 bits
Memory:1.8 GiB
Processor:Intel® Celeron® CPU N3050 @ 1.60GHz × 2
Graphics:Mesa DRI Intel® HD Graphics 400 (Braswell)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Hey there!

What browser are you using?

2gigabytes of Ram is minimal on the wiki, and I can attest it is a much more comfortable with 4 gigabytes or more.
https://docs.parrotsec.org/info/system-requirements/

:face_with_monocle: I see you have 1.8 gigabytes of ram. This definitely can lead to maxing out of resources, depending on websites/tabs/other apps open.

Have you tried any other browsers? This might be something worth looking into :slight_smile:

1 Like

Hello,and thanks for the response.

yes,it’s a very limited system in terms of,well,everything…
from what i understand this system can’t be upgraded either.
it was given to me by someone who didn’t want it because the screen wasn’t coming on,turns out,it was just unplugged.
so i figured i would experiment with it a bit,so here i am as a first time linux user…
i must say,i do like the fact the ParrotOS for the most part is pretty stable,especially given the fact that this machine had pretty much reached it’s end when it comes to windows updates,due to the limited available space.
i had to delete everything possible and barley made enough room to download this OS.

it runs a 32GB emmc,so i guess you might say it was the prototype for the galaxy fold,with worse specs of course…
that being said,a ParrotOS to android devices seems very much possible if machines like this can handle it…

but to answer your question,the browser that was creating the issue was the ParrotOS firefox mod.
it became pretty much unusable,though doing an edit to create a Zshare swap partition to improve ram performance seemed to help a bit.
finally,i just decided to delete the preinstalled version of firefox and install the updated version for linux,to see if it still happened,and thus far the answer is no…
i installed the addons from parrot,but i’m not sure what other changes were done by Parrot for privacy?
it would be good to know,because if i could compare the two versions.
I’m pretty sure i could locate why the Parrot version isn’t stable on this particular system and a few others that reported the same thing but don’t seem to have found any resolution…

if you know those setting,or can recommend a reliable browser,it would be appreciated…

Well Brave Browser is good to try.

I looked at that one,but it seemed overly complicated to install…
it’s not in the snap store any longer either,for security reasons they say…?

I would definitely be willing to try it if i could find some straight forward instructions…

Well just do these serially:

  1. sudo apt install apt-transport-https curl

  2. curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

  3. echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list

  4. sudo apt update

  5. sudo apt install brave-browser

Full documentation here: https://brave-browser.readthedocs.io/en/latest/installing-brave.html

2 Likes

weird thing is,i have tried those very same commands before,with no success.
but,for whatever reason,they worked,go figure…?
i appreciate it!

1 Like

Haha nice for now as it works
it is lightweight as compared to firefox but not in a big scale but give it a try
it may workout

2 Likes

Bro,it’s far better than what i was dealing with.
i was trying to download it for a day,hoping it would work,but it just wouldn’t.
it seems to be based on chrome,which i wasn’t all that excited about as i try to avoid google as much as possible…
but as far as performance, and multitasking,the machine is now usable again,which is great!
once again,thank you!

2 Likes

yeah it is based on chromium engine but it got google reporting ripped of so it iss worth a try haha

2 Likes

@nova you can give a try out to LibreWolf
(A Fork of Librefox & Originally Firefox)


its a bit new thus not known widely (i too use it)
2 Likes

Thank you both!
brave browser is working with no issues,so i’ll likely stay with that for now…

off topic,but I’ve been trying to install wine but i cant get it to work since i did the install.
at first it appeared all was well but when i went to install it i couldn’t…?
now i can’t even find the program…?
i’ve read through the thread and online yet still i cant seem to make any progress with it…
do either if you have experience with it that could get me further along?

thanks in advance…

for running wine, you can just do
sudo apt install wine as wine is in the repo.
For enabling 32bit applications in 64bit, you need to do
sudo dpkg --add-architecture i386
after that you can install wine32 as well
sudo apt install wine32
and to configure wine
you can just run winecfg

2 Likes

Hey did you added swap to your system? It helps to cool off some amount of stress on ram of your system

1 Like

He has added ZSWAP through ZSHARE, better than swap

2 Likes

Yes,i have.
my only concern with it is the issue that some mention with enabling it on an eMMC machine.
some say that it will degrade the flash storage much quicker,and others say that android devices do it often,so it’s really no different…?
you guys would understand that more than i would,but i can grasp the concept…

here are the two edits I’ve used…

this one works well,though it does appear to cause some glitching during usage,but hasn’t caused any major issues that i’m aware of…
(keep in mind,i’m a short order cook in the world of master chef’s here,so take that assessment with a grain of salt…)

GRUB_CMDLINE_LINUX_DEFAULT=“quiet zswap.enabled=1 zswap.compressor=lz4 zswap.zpool=z3fold”

with this edit,i experience less glitch during browsing,which is mostly visible on the mouse cursor when browsing,not the actual page itself.
this is the one i’m currently using,and is also the original edit i started with when the issue with firefox was at its worst…

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash zswap.enabled=1 zswap.compressor=lz4”

so,i can’t tell you if the edit did much,it’s possible that firefox was just too heavy of a program for this machine to handle with linux,and such low device specs…?
but i can say that with the edit enabled and switching to the brave browser,the machine hasn’t crashed,the pages haven’t stalled,and the device works well while multitasking…

1 Like

well yeah those sort of things make more use of your drives especially in cases like yours haha
and hard disks are much durable so i can that can handle (can’t say in case of ssds)
also regarding those tabs, if you are into more tabs you can use one tab extension that just bundles up all the tabs at one place. that way you can have even lesser ram usage

1 Like

I’ll look into that,thank you!

Aside from that,i just installed Apache HTTP Web Server,and it’s easy for me to say that it’s the most noticeable improvement to performance made thus far…

https://www.2daygeek.com/install-apache-httpd-web-server-on-linux/

that,along with the zSWAP mod with brave browser really make it feel like a different device.

When using windows 10,this thing was completely awful…!
at this point,aside from the steep learning curve,(which i’m fine with),i have to say that i’m glad that i switched over!

2 Likes

Haha glad that you are having wonderful experiences haha

2 Likes

Hi there,
I have just followed the steps but not able to locate the brave browser in my system
Release 4.9 64-bit
Kernel Linux 5.5.0-1parrot1-amd64 x86_64
Release 4.9 64-bit
MATE 1.24.0
Memory:-3.7Gib
Processor:Intel® Pentium® CPU N3700 @ 1.60GHz × 4
Graphics:Mesa DRI Intel® HD Graphics 405 (Braswell)

1 Like