Take ownership of drives

Briefly describe your issue below:
Take ownership of drives and auto mount on boot as user?

I got a new Evo 970 M.2 drive so ran a fresh install

I have tried using my previous fstab file to auto mount my internal HDD and 2 ext USB drives

this is my fstab file

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p2 during installation
UUID=c8b6fa43-4cfa-47c8-9e5f-5b34ba179530 /               xfs     defaults        0       0
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=37AD-2CF0  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/nvme0n1p3 during installation
UUID=a34a2152-a94a-4bc7-a63c-34445750c138 /home           btrfs   defaults        0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
UUID=ddffc664-35a8-448e-b353-85bb30a4bb74 /media/hdd0 ext4 defaults 0 0
UUID=36AC820DAC81C837 /media/hdd1 ntfs defaults 0 0
UUID=7842FDC342FD8662 /media/hdd2 ntfs defaults 0 0

I also tried UUID=7842FDC342FD8662 /media/hdd2 ntfs user,auto 0 0

and UUID=7842FDC342FD8662 /media/hdd2 ntfs uid=1000,gui=1000, 0 0 - system went into maintenance mode so I removed the uid=1000,gui=1000, and replaced with default

I have tried unmounting the drives and as root running sudo chown username:username/media/hdd2 -R
for each drive but still shows root?

While they are mounting I can access the drives all the files and folders are owned by root

What version of Parrot are you running? (include version, edition, and architecture)

Parrot Home 4.5.1

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

You should be able to add umask=000 to the mount options. That should allow you to read, write and execute on the drive.

Something like

UUID=36AC820DAC81C837 /media/hdd1 ntfs rw,user,exec,umask=000 0 0

Thanks I guess I replace user with my username ?

Nope user just means that the drive can be mounted by somebody other than root.

1 Like

Tried that but same permissions root root
this is for the 2 external usb drives

UUID=36AC820DAC81C837 /media/hdd1 ntfs defaults  rw,user,exec,umask=000 0 0
UUID=7842FDC342FD8662 /media/hdd2 ntfs defaults  rw,user,exec,umask=000 0 0

tried chown username:username/media/hdd2 -R as root after unmounting the drives 



You left in defaults. Try removing it and see if it has any effect.

Changed to

UUID=36AC820DAC81C837 /media/hdd1 ntfs rw,user,exec,umask=000 0 0
UUID=7842FDC342FD8662 /media/hdd2 ntfs rw,user,exec,umask=000 0 0

same still root, tried running caja as sudo when I change owner to username it reverts back to root

Not sure if this is related but during boot I see this

After I removed the auto mount from fstab the above does not show during boot

I have plugged the drives in after boot but they don’t show - going to try a reboot with them connected …

Ok I get a load of new messages - however when I click on the drives they open and all the folders are now username - what I find odd is I never had this problem before I changed my main M.2 drive and switched to Home instead of Security version

I used
UUID=36AC820DAC81C837 /media/hdd1 ntfs defaults 0 0
UUID=7842FDC342FD8662 /media/hdd2 ntfs defaults 0 0

and this worked fine no error screens on boot and I was the owner - I thought the only difference between security and home was the tools?

thanks for all your help

I think im more confused now than when this thread started.

So the problem was the owners of the files? not permissions to mount and modify files on the drive. Because ntfs doesnt support linux file ownership like ext4 or btrfs.

Sorry for the confusion, I change my drive reinstalled Parrot - updated system - reboot

set fstab as I had it previously - rebooted - drives show up

checked folder permissions all set as root - previous install both drives were my username

and I never had the error screen I posted above - it would seem if I auto mount the drives the owner gets set as root - if I remove them from the fstab and plug them in after boot - permissions is in my username

I changed drive and switched to home version?? and this is the error I didn’t use to get before I switched drives.

So is it working for you now or doing what you want?

Because like i say, ntfs doesn’t support Linux file ownership.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.