Temporary failure in name resolution

*-- hello, I’ve just installed parrot os and I can’t use the internet. I can connect to the network, but I can’t access the internet, pinging google.com or anything just gives me Temporary failure in name reolsution.

I’ve tried reinstalling, modifying my resolv.conf file but it’s configured correctly, disabling firewall completely as well as allowing ports 53 and 43 on tcp, I can use the internet just fine with USB tethering from my phone, however wifi doesn’t seem to work.

Any help? I’ve also tried reinstalling from a redownloaded ISO. --*

  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION): latest version, 5.14.0-9

  • Logs/Terminal output (use pastebin or similar services): ping: google.com: Temporary failure in name resolution

Can you please show your resolv.conf?



Do you have anonsurf running? Sometimes anonsurf will mess up DNS due to using TOR.

the dns are set correctly.
Try to force stopping anonsurf and see if you still have the issues.

1 Like

nope, I don’t have it running

just did, same problem. seems to be unsolvable, I think I’ll just install parrot on my main machine and see if the problem persists

if you’re using the beta version please report this in the proper thread

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.