Tor browser not starting

Not sure if I have the correct group. I just installed (first time) the Parrot OS on my computer (yesterday, 1/23/18). I have everything else (so far) working correctly and smoothly. I tried to start up the Tor browser and it does nothing. I don’t get an installation screen or anything else…it just sits there. I can run all the other programs just fine.

I have tried to re-install the browser from the package manager, marked it as complete removal, then re-install, removed and installed it from the command line. So far, nothing seems to work. I can get the browser launcher settings to work, but the browser itself never seems to start. I have tried just leaving the OS up and running as well as doing reboots in-between each action. Nothing seems to be working…suggestions would be appreciated.

Parrot OS is the only OS on this computer. I have verified the drive was completely wiped prior to installation of the OS, using the guided installation downloaded (security) straight from the Parrot OS site.

hi, the firefox browser package has nothing to do with the tor browser launcher

have you tried to dist-upgrade the system?

I just did that, didn’t install anything new. I clicked the re-install browser from the launcher settings (since I missed it the first time). It flashes across the screen that it’s initializing or something, then goes to the download / installing for the first time bar and sits there. Never actually downloads.

if the launcher is not able to install the latest tor browser then there is something wrong between you and the torproject servers, if it is not you, then it depends on them

do you ses any option to select another torproject download mirror?

yes I did. I have tried a couple different mirrors (since I know there is the occasional issue with connections…maybe not choosing the right mirror to download from? Besides the main one, I just chose a couple at random to try. same results. Firefox browser is letting me surf the net no problem, so I don’t think it’s a connection issue…but then again, it’s probably the operator behind the keyboard.

hmm…now it says installed, but still can’t start the browser…probably a setting I’m missing somewhere?

Ok, I was on another forum asking the exact same question and now have the answer. For everyone else who might have the same issue, this is a condensed version of the answer I received:

“Go to torproject.org, download the program directly from there and install according to the directions given.”

What the problem seems to be is that the script used to install Tor is either not functioning (for me), or might need someone to tweak it and make sure it’s not broken somehow. I had been using the tools provided by the parrot OS. Instead, follow the torproject.org instructions and I had it up and running in only a few minutes.

have you dist-upgraded the system? is the tor daemon correctly up and running?

Hi,

Ive the same issue, Ive dist-upgrade the system but Tor browser seems to don`t want to start…

Now i try to install directly from torproject.org as raccomended by @new2linux and check if the problem persist

Installing the package from torproject.org the browser start without any problem

It seems the torbrowser-launcher in /usr/bin/ fails due to the new tor browser version update.

details:

└──╼ $torbrowser-launcher
Tor Browser Launcher
By Micah Lee, licensed under MIT
version 0.2.8
hxxps://github.com/micahflee/torbrowser-launcher
Refreshing local keyring…
Keyring refreshed successfully…
No key updates for key: EF6E286DDA85EA2A4BA7DE684E2C6E8793298290
Traceback (most recent call last):
File “/usr/bin/torbrowser-launcher”, line 30, in
torbrowser_launcher.main()
File “/usr/lib/python2.7/dist-packages/torbrowser_launcher/init.py”, line 62, in main
app = Launcher(common, url_list)
File “/usr/lib/python2.7/dist-packages/torbrowser_launcher/launcher.py”, line 91, in init
if not self.common.settings[‘installed’] or not self.check_min_version():
File “/usr/lib/python2.7/dist-packages/torbrowser_launcher/launcher.py”, line 603, in check_min_version
for line in open(self.common.paths[‘tbb’][‘versions’]).readlines():
IOError: [Errno 2] No such file or directory: ‘/home/user/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/TorBrowser/Docs/sources/versions’

Tor Launcher Settings in the Parrot Menu will reinstall a new version of the browser, but its the launcher that is causing the error.

a workaround one quick fix is to

launch start-tor-browser in the /.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser directory.

or

start-tor-browser.desktop in ~/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/

Edit-

Github issue raised.

1 Like

then it is a bug in the debian package…

let’s wait for a new upstream version

This solved my torbrowser.
Thanks !

1 Like

Might be a little late to the party! But I’ll give my experience anyways.
I used to start up Anon surf and then try to start the tor browser. I would get the installer to hang at 0 every time. I thought that the Terminal saying “Starting tor” Meant it was going to start the browser. But this is false. Instead, you need to think of the two as a seperation. If you want to surf anon and just hang out. You would start anonsurf and when you get the Okay just open firefox and browse. However, if you wanted to use the Tor browser to surf a little deeper you dont actually need the anon surf toolkit. In fact it’s not a great idea because when you start Anonsurf and then try and use tor you start torception and that isn’t good. The mention of “starting tor,” in your terminal refers to the tor service, and not the Tor browser. You’ll notice if you start the anonsurf service and type:

(I’m not sure how to use the code filter on this site yet, sorry.)

sudo service tor --status

EDIT: forgot to disable anonsurf
You’ll see that the tor service is ACTIVE. Disable the anon surf and proceed.

Instead of using that first, try this. (This is what fixed it for me.)

sudo apt update

sudo apt full-upgrade

edited by Palinuro
notes: use dist-upgrade or full-upgrade instead of upgrade, we are a rolling release distro

Just in case :stuck_out_tongue:

Then I had to remove the tor service entirely. Thankfully there’s a newbie function for this.

sudo apt-get autoremove tor

This should remove everything related to the tor service. In my case it removed the broswer as well.

sudo apt-get install tor

Then once more

sudo apt-get update

sudo apt-get upgrade

Restart for good measure. And once you’re back online instead of starting anon surf just run the tor browser client. Apps>Internet>Tor Browser. Use auto configure if you’re super green like me and you should be fine. At anytime it’s a good idea to make sure that the tor service isn’t running when tyring to use the browser. You can do this by entering the same command as before.

service tor --status

I hope this helps and all of the vets out there please corrent me if I’m wrong.

.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser
You can also add Tor Browser to your desktop’s application menu.
Copy and paste

If you make a .txt file with “/home/user/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/start-tor-browser” in it and double click it and click run in terminal it will open Tor.

I’ve updated different versions of parrot and Tor hasn’t been working for a while but that works. Maybe somebody knows how to modify whatever folder to get it to open normally but it’s not a big deal.

1 Like

To solve this, there are 2 options:
Before doing anything, you have to find your tor-browser start file by
sudo find / -name "start-tor-browser"

Normally, it is at,
.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/start-tor-browser

#1
You can run tor-browser from the terminal by
.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/start-tor-browser

#2
If you do not want to run by the terminal and run by click on tor icon instead,

you have to edit your tor-browser.desktop file by
sudo vim /usr/share/applications/torbrowser.desktop

Then edit
Exec = /home/YOURUSERNAME/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/start-tor-browser

After this it should be work, good luck…!

1 Like

im also having the same trouble it says no iptables and when it activates anon surf its still showing my normal Ip this is after fresh install to new pc

torbrowser-launcher enter