Tor does not work

Hi after some system upgrade about month ago my Tor stopped working even I reinstalled it, and I don’t have anymore anonsurf mode options. When I run tor browser I can see just black window. Would be great if you can help me.

Its an apparmor issue. Did you search the community before posting? :wink:

Here. Have a look at this recent thread


You’re a hero. Can you tell me why there is no anymore anonsurf mode in parrot?

Thank you.

1 Like

Well, that was undeservingly overwhelming :joy: :smile:

This seems to be an issue with your system. Anonsurf is still there in parrot. In case you think its may be missing, you can always install it back to your system.

Here, try this.

sudo apt update

Once updated, lets skip all the command line stuff for your ease :wink:
Go to synaptic package manager, search for anonsurf, right click on the package, hit install.

I hope you know the anonsurf usage via terminal, if you don’t, here are basic two basic syntax to get you going

sudo anonsurf start to start routing your network through tor
sudo anonsurf stop to stop routing your system through tor.
sudo anonsurf restart to restart the routing.
sudo anobsurf myip to check your IP
sudo anonsurf status to check the anonsurf status

This should get you going :smile:


You are Hero of the Heros :smiley:
Thanks man :stuck_out_tongue_winking_eye:

1 Like

Mark the solution if the issue is solved, the thread will be closed :smile:

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.