Unable to connect android device

– Please Write here your help request, –
Android Device Not detected

I tried to connect my android device to my laptop but i parrot is not recognizing the device
I have enabled file sharing in my phone
I tried of using different cables but no use
I can connect my phone to other laptops but my laptop is not recognizing

I am using Android 9

  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):
    Parrot OS 5.0 (LTS)

  • Kernel version (if you are not aware of it, open terminal and type uname -r):

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:
    screenshot of lsusb

    Device 009 is my phone

    screenshot of fdisk

    dmesg info

1 Like

Hello. To find your phone go to the panel wich shows the hard drives. Click on your phone and press open with file manager. Then you will have access to your phone’s folders

1 Like

Configuration may vary depending on mobile phone models.
Go to Settings, turn on USB Debugging and after connecting the USB Cable, ensure that you’ve chosen Photos / Gallery mode.

This perfectly works on Huawei, Samsung & Nokia phones.

yaa I have turned on usb-debugging but still it’s not showing

1 Like

can u pls tell me how to navigate to that hard ware panel

If USB-Debugging is on, you need to check these:

  1. From Settings, go to About Phone and tap the Build Number option 7 times
  2. Turn on “Developer Mode
  3. Turn on “Stay Awake

Your phone should be connected by now and your phone’s icon should be visible inside Parrot PC’s Home .

phone has 3 options
just to charge / just to share photos / to share all files
to see your phone in your system, enable files from the above options
you might get to choose these options from notifications when u plugin your phone or you might have to go to settings>storage.

I already mentioned above that i turned on file sharing

No still didn’t resolve

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.