Update failed with unmet dependencies

Hello everyone, since 2 days when I try to update my ParrotOS, I receive a lot of errors (unmet dependencies).
I tried to install the requested packages, but it seems that they’re already installed, tried with all the normal operation of fixing broken packages or dependencies ( apt install -f, dpkg --configure -a, ecc…) without any results.
The sources list haven’t been edited.

I’m running Parrot GNU/Linux 4.9 Security edition x64 (MATE) but with KDE installed manually.

Installed with Debian GTK.

No multiboot.

LOG:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
apache2 : Depends: apache2-bin (= 2.4.43-1) but it is not going to be installed
apktool : Depends: aapt
apt-config-icons : Depends: appstream but it is not going to be installed
backdoor-factory : Depends: osslsigncode
bind9-host : Depends: bind9-libs (>= 1:9.16.2) but it is not going to be installed
binutils : Depends: binutils-x86-64-linux-gnu (= 2.34-8) but it is not going to be installed
chirp : Depends: python-libxslt1 but it is not going to be installed
Depends: python-libxml2 but it is not going to be installed
claws-mail-i18n : Depends: claws-mail (>= 3.17.5-2)
default-jdk : Depends: default-jdk-headless (= 2:1.11-72) but it is not going to be installed
Depends: openjdk-11-jdk but it is not going to be installed
default-jre-headless : Depends: openjdk-11-jre-headless but it is not going to be installed
glib-networking : Depends: libproxy1v5 (>= 0.4.14) but it is not going to be installed
Depends: glib-networking-services (>= 2.64.2-1)
Depends: glib-networking-services (< 2.64.2-1.1~)
gnuplot : Depends: gnuplot-qt but it is not going to be installed or
gnuplot-x11 or
gnuplot-nox
grabber : Depends: python-libxml2 but it is not going to be installed
gvfs-daemons : Depends: libbluray2 (>= 1:0.2.2) but it is not going to be installed
libavcodec58 : Depends: librsvg2-2 (>= 2.14.4) but it is not going to be installed
Depends: libsnappy1v5 (>= 1.1.8) but it is not going to be installed
libc6:i386 : Depends: libgcc-s1:i386 but it is not going to be installed
libfluidsynth2 : Depends: libjack-jackd2-0 (>= 1.9.10+20150825) but it is not going to be installed or
libjack-0.125
libglx-mesa0 : Depends: libgl1-mesa-dri but it is not going to be installed
libgtk-3-0 : Depends: librest-0.7-0 (>= 0.7) but it is not going to be installed
liblouisutdml-bin : Depends: liblouisutdml9 (>= 2.8.0) but it is not going to be installed
libnice10 : Depends: libgupnp-igd-1.0-4 (>= 0.2.4) but it is not going to be installed
librdf0 : Depends: libraptor2-0 (>= 2.0.14) but it is not going to be installed
Depends: librasqal3 (>= 0.9.31) but it is not going to be installed
libsane : Depends: libgphoto2-6 (>= 2.5.10) but it is not going to be installed
libsnappy-java : Depends: libsnappy-jni but it is not going to be installed
libswresample3 : Depends: libsoxr0 (>= 0.1.0) but it is not going to be installed
libtag1v5 : Depends: libtag1v5-vanilla (= 1.11.1+dfsg.1-2) but it is not going to be installed
libvoikko1 : Depends: libhfstospell10 but it is not going to be installed
libvpx6:i386 : Depends: libgcc1:i386 (>= 1:4.2)
lightdm : Depends: lightdm-gtk-greeter but it is not going to be installed or
lightdm-greeter
lightdm-parrot : Depends: slick-greeter but it is not going to be installed
lightning : Depends: thunderbird (>= 1:68.8.1-1) but it is not going to be installed
man-db : Depends: groff-base (>= 1.18.1.1-15)
mariadb-server-10.3 : Depends: mariadb-client-10.3 (>= 1:10.3.22-1) but it is not going to be installed
Depends: mariadb-server-core-10.3 (>= 1:10.3.22-1) but it is not going to be installed
mate-core : Depends: mate-desktop-environment-core (= 1.24.0+1) but it is not going to be installed
mono-runtime : Depends: mono-runtime-sgen (= 6.8.0.105+dfsg-3) but it is not going to be installed
nginx-full : Depends: libnginx-mod-http-dav-ext (= 1.16.1-3) but it is not going to be installed
Depends: libnginx-mod-http-xslt-filter (= 1.16.1-3) but it is not going to be installed
nodejs : Depends: libnode64 (= 10.20.1~dfsg-1) but it is not going to be installed
openjdk-11-jre : Depends: openjdk-11-jre-headless (= 11.0.7+9-1) but it is not going to be installed
pack : Depends: python3-enchant but it is not going to be installed
parrot-core : Depends: apt-parrot but it is not going to be installed
Depends: dnsutils
parrot-menu : Depends: gksu but it is not going to be installed
parrot-themes : Depends: gtk3-engines-breeze but it is not going to be installed
Recommends: humanity-icon-theme but it is not installable
passing-the-hash : Depends: smbclient (>= 2:4) but it is not going to be installed
postgresql : Depends: postgresql-12 but it is not going to be installed
powerfuzzer : Depends: python-wxtools but it is not going to be installed
python3-zmq : Depends: libzmq5 (>= 4.2.0) but it is not going to be installed
ruby-espeak : Depends: espeak
shared-mime-info : Depends: libxml2 (>= 2.7.4) but it is not going to be installed
soapysdr0.7-module-all : Depends: soapysdr0.7-module-airspy but it is not going to be installed
Depends: soapysdr0.7-module-audio but it is not going to be installed
Depends: soapysdr0.7-module-bladerf but it is not going to be installed
Depends: soapysdr0.7-module-hackrf but it is not going to be installed
Depends: soapysdr0.7-module-lms7 but it is not going to be installed
Depends: soapysdr0.7-module-osmosdr but it is not going to be installed
Depends: soapysdr0.7-module-redpitaya but it is not going to be installed
Depends: soapysdr0.7-module-remote but it is not going to be installed
Depends: soapysdr0.7-module-rtlsdr but it is not going to be installed
Depends: soapysdr0.7-module-uhd but it is not going to be installed
tasksel-data : Depends: tasksel (= 1:3.53+parrot2) but it is not going to be installed
Recommends: laptop-detect but it is not going to be installed
tshark : Depends: libwireshark13 (>= 2.9.0) but it is not going to be installed
Depends: wireshark-common (= 3.2.4-1) but it is not going to be installed
ure : Depends: uno-libs-private (= 1:6.4.4~rc1-1) but 1:6.4.4-1 is to be installed
Depends: libicu63 (>= 63.1-1~) but it is not going to be installed
Depends: liblangtag1 (>= 0.4.0) but it is not going to be installed
Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not going to be installed
Depends: libuno-purpenvhelpergcc3-3 (>= 1.4.0) but it is not going to be installed
Depends: libxml2 (>= 2.8) but it is not going to be installed
Recommends: libjuh-java but it is not going to be installed
Recommends: libjurt-java but it is not going to be installed
va-driver-all : Depends: mesa-va-drivers but it is not going to be installed
vdpau-driver-all : Depends: mesa-vdpau-drivers but it is not going to be installed
volatility : Depends: python-openpyxl but it is not going to be installed
wine64 : Depends: libwine (= 5.0-4) but it is not going to be installed
Recommends: wine32 (= 5.0-4)
wireshark : Depends: wireshark-qt (= 3.2.4-1) but it is not going to be installed
wpscan : Depends: ruby-cms-scanner (>= 0.10.0) but it is not going to be installed
xserver-xorg-core : Depends: libunwind8 but it is not going to be installed
Recommends: libgl1-mesa-dri (>= 7.10.2-4) but it is not going to be installed
xserver-xorg-video-vmware : Depends: libxatracker2 (>= 11.1.0~) but it is not going to be installed
zulucrypt : Depends: zulucrypt-gui but it is not going to be installed
Recommends: zulumount-gui but it is not going to be installed
Recommends: sirikali but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Try with:
sudo apt --fix-broken install
it should download and install all packages you need to continue

Actually apt install -f and apt --fix-broken install are the same commands

1 Like

And magically, today, repositories has been fixed.
Thank you parrot’s repository maintainer :wink:

Ohh, great!

Hello… just coming back from windose10 and tried to install Parrot 4.10 Security today and got some error install… (sorry that I don’t see real good, so I may have misspelled one of the words.)
"Installation Failed Bad unquash configuration
The file system “run/live/medium/live/System.squashfs does not exist.”
That is all I can see… I did the above suggestion on …sudo apt --fix-broken install
And got did not work
Tried the second which told me I had file to remove… So I sudo that file and it be gone so I did the first apt --fil-broken install and that went to asking me if I wanted to upgrade something… (sorry) I didn’t get that screen shot))
BUT… I’m still in USB live with persistence and have to much catching up 5 days without a laptop! WOW!
Any one know how or why on that ERROR for Bad Install?

this squash error basically arises when you burn the usb badway or incorrectly
use BalenaEtecher to burn the usb as suggested and it should fix the issue.
Documentation: https://docs.parrotlinux.org/getting-started/create-boot-device/

Hey thank you very much, for your support time!

I did see that Etecher (thank you,) but couldn’t install it to Mint, nor to Parrot to do the Etecher install…and I have no OS…so I just booted to Ventoy dropped Parrot OS and booted to that.

Choose Parrot with persistent (?sp.) which does NOT work saving anything I add.

So I’m in Parrot Security 4.10 and tried to do the Etecher thing in terminal and got cmod u+x balenaEetchern-1-5.105-x64.-Applmage … not found!

I have my FONT as large as I can get it without messing up the box I’m viewing so, I don’t really like to do very much “terminal” typing, or coping, and pasting since I can’t really “SEE” what is in the boxes until I have an OS installed in my machine / laptop and USE the Magnifier to Blow things up to see them!

I installed Parrot OS, this one I’m squinting at now to almost view this support reply box.

I don’t understand why, since I’m IN Parrot Security OS, why IT can’t just do the … take over entire drive and install it’s own / and home and boot and all that automatically, and correctly and bingo, good to go! LOL!
I did on Parrot 4.4 or something 1.5 years ago.

Again thank you! I’ll keep trying to install Etecher thing in Parrot!

If you have an adapter for plugging an sd card in to an android phone you can write Linux ISO’s directly from your phone. The app is called EtchDriod I’ve used it for Parrot, Manjaro, Endeavour, Arch Linux, Debian, etc. I actually prefer to use it for writing ISO’s because I keep all of them downloaded in my internal storage on my phone and can write any them within seconds. It works great for me because I often have slow, or no internet connection and used to hop distros often. Plan on sticking with Parrot now for awhile but I still have 4 distros installed on top of Windows. dd is the recommended way to write ISO’s however Etcher is a great application and i’ve never had an issue using it.

I do thank you for your fine suggestion!

I have an droid, and I have the sd card, and when I plugged the sdcard into Parrot Security running off usb stick, all I saw on the SDcard was trash special characters! So that is “corrupted” and really unusable, till I get it fixed, reformatted.
I tried gParted and that was worthless as it didn’t even SEE the sdcard the second time I put it in my Dell. Gparted doesn’t see only 2 of 4 usb sticks!
I going to try to get Eticher installed tomorrow.

I’ll try to get the sdcard formatted and get the apk at apkpure tomorrow also!

Again… thank you and the rest of this forum for support, as I really want to get Parrot installed asap!

Stay safe!

well if you can go upto the terminal you can use dd command to do the work

sudo dd if =parrot.iso of =/dev/sdb
at if flag, specify the location of the iso
and
at of flag, specify the device

1 Like

Thank you for your support!
That is a good suggestion, but I’d love to have persistence since my Dell is NOT booting to the internal SSD, and only boots to usb sticks.
I had UEFI inabled without other ROMS and than with other roms.
F2 rebooted turned Secure boot OFF than rebooted to get to SSD partition, and get “No Bootable Devices” until I put a usb stick in, as “boot to usb” is second choice.

SO I used Venroy when on Winders10 and choose Parrot 4.10 with persistence and THAT does not provide persistence.

I have Unetbootin .bin to do the usb install but like Eticher I need to learn code for .bin or tar.zip (short memory…lol)

So…again thank you for that suggestion, but without a bootable SSD Drive I be on usbs only until I get to youtube university to learn how to fix that malfunction!

Later and stay safe!

yeah sure brother
stay safe

Thank you all for great support, on this great OS!

Well I “TRIED” another install, with same Ventoy Parrot 4.10 64 bit and this time I also did the same …“complete erase,”
but this time I checked the box with add “swap with hibernate,” Rebooted and I was Looking at Parrot on my laptop.
That was the great news!

NOW for the other news,
I had written down my password that Ive been using for way “to long”, in the “install setup,” and so when it installed it didn’t take my correct password, that I know, was the PW I used on setup install.

SO I be back on another Live USB that I choose “Parrot with persistence,” and it doesn’t persist, and asks for a PW coming out of sleep mode, when NONE was setup in the first place?
WHY/

Sorry I really wanted to post this in Parrot “4.10 bugs reporting,” so I didn’t get off topic here, but couldn’t find the link/ url/ button to submit that password bug(s,) and the “NO persistence” for the live USB on Ventoy, when it was chosen before boot up to Parrot!