Upgrade stuck at apt (1.8.1+parrot1)

I use Parrot Security OS on a RaspberryPi 3B+. Only additional package is wpasupplicant.
Version is from 07.03.2019. sorry.
I have ssh access.
When I run “sudo apt-get install upgrade” (after apt-get update), it says that I have killed the last one (i did, because it was stuck there too), and now I have to run “sudo dpkg --configure -a” but when I do that, it stops at "Setting up apt (1.8.1+parrot1). I had to reset because of this issue and now its here again. Any ideas?

You ever thought about letting it stay there for a while, it might just need a long time. On a side note I wasn’t aware the arm images actually worked…

I dont know what you mean with long, but it has been running now since 8hours. enough?
Update: i found the log. maybe it helps.

Ok so, for those who may have similar problems. I made a fresh install and uninstalled apt and apt utils i think. Then I redownloaded a nornal apt package from debian.org. Then I reinstalled the packed with dpkg.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.