USB flashed with parrot not booting

Briefly describe your issue below:
Hello all! I can’t seem to get parrot to boot off my usb drive.

I’ve tried flashing the parrot iso (4.9.1 security mate) to my flash drive numerous times but it doesn’t boot correctly. Ive used dd and balena etcher. When I use the link to the iso ( balena gives me an error message “missing partition table. it looks like this is not a bootable image”. I also tried the kde version and an older version of parrot, 4.5, and had the same issues.

I tried flashing ubuntu to the usb stick and it worked fine and booted up correctly, so I know the process should work theoretically. However, when I chose the usb from the boot menu the screen turns black and the boot menu pops up again immediately.

Anyone know why I’m having trouble getting the iso to boot?

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Hello, that some weird problem.
You can try again using the etcher on lower Parrot Versions.
You can find them here:
Try 4.8 and from there do sudo parrot-upgrade.

I’ve tried several versions already, including 4.9.1, 4.9, 4.7, and 4.5. Unfortunately I’ve had the same problem each time…

Do you mean mate? I haven’t actually tried KDE, I’ve just been trying different mate versions.

from a terminal as root user type

dd if=/home/user/Downloads/Parrot-security-4.9.1_x64.iso of=/dev/sdb bs=4M

if= the location of your parrot iso
of= the location of our usb drive your writing to

it takes a while to copy the iso to the usb

then once you reboot you should choose boot options then select the usb drive, once the grub loads, select live and parrot desktop should load perfectly

I’ve already tried dd several times, but unfortunately attempting to boot off it just causes the screen to turn black for a moment then to return to the boot menu.

disable your secure boot option in your bios, that way you can boot any other operating system other than your computers main software system.

1 Like

Wow that fixed it- thank you!! Can’t believe I didn’t try that…

1 Like

great stuff, im glad it fixed it for you, enjoy parrot :smiley:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.