Using Chrome in Parrot with a Proxy

I have Parrot installed and working but I have one issue. I can’t get Chrome or Chromium to work through our corporate proxy. Has anyone else had any luck getting Chrome to play nice in Parrot?


What version of Parrot are you running? 4.1

What method did you use to install Parrot? Debian Standard

Configured to multiboot with other systems? no

how did you installed chromium? could you be more specific on your issue?

does firefox work?
how does your corporate firewall work?
does your company provide any instructions on how to surf the web?
at which level have the firewall blocked you? at dns level? wrong https certificate? routing problems?

I’m having a similar issue. Firefox browser works. Terminal also uses the system proxy. However both chrome and chromium don’t work. It is a simple proxy address with a port number with no authentication. I also tried to edit chrome proxy settings and launch chrome with the proxy settings but neither worked.


google-chrome-stable --proxy-server=""

When I search for Chrome Browser Proxy settings, I get the message below.

When running Google Chrome under a supported desktop environment, the system proxy settings will be used. However, either your system is not supported or there was a problem launching your system configuration.

But you can still configure via the command line. Please see man google-chrome-stable for more information on flags and environment variables.