Using Live breaks my local parrot


#1

Briefly describe your issue below:

If i install Parrot on my system, when going to the boot options in bios i can see my boot partition, but if i once plug a live USB (parrot or anything else) and boot on it, when i reboot, my boot partition from my local parrot install will disappear, which makes my system not possible to boot.
I never got that before, so i don’t know how to solve it yet… Though i know it’s not about needing to reinstall grub because the issue is not me booting on parrot and failing, but rather that even in my bios, in the boot setup there is no parrot boot anymore. Maybe it’s an issue with UEFI, and i should install parrot next time using ext4 bootable instead of EFI boot partition ?

What version of Parrot are you running? (include version, edition, and architecture)
Linux parrot 4.18.0-parrot10-amd64 #1 SMP Debian 4.18.10-2parrot10 (2018-11-17) x86_64 GNU/Linux
Parrot Home version
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard
Configured to multiboot with other systems? (yes / no)
no
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Nico Paul) #2

use the 4.4 iso and leave default partitioning to btrfs. you do need grub of some kind if no other systems present (some bootloader. ~700MB)


#3

Mybad i forgot to add that i’m using Parrot 4.4 Home. I tried doing manual partionning and another time letting the installer do everything (which btw doesn’t add a swap partition automatically in contrary to debian installer, is that normal ?). And yea i tried ext4 and btrfs for the root partition, still bug.

So the thing is i have grub since i can boot on my system, do anything i want for days or weeks, but the moment i’ll plug a live usb (Home,Security,Kali…), my local install will vanish from the boot options when i reboot after my live session.


(Nico Paul) #4

i would say that stuff gets mixed up because of the fixes and stuff, i recommend backing up and reinstalling your setup that way its not messy. you actually dont need a swap partition with btrfs because it doesnt support swap files (it would actually be anti-btrfs) which is something that i had to take a minute to read about why that is, which you can do here!


#5

thanks for the link, i never used btrfs before, just knew it’s the new recommended partition system. i have only 4gb of ram though, it won’t be a hindrance to use btrfs without swap ?

i don’t understand what you are saying about reinstalling ? if i reinstall everything work again until i’ll plug a live usb and the problem comes back.


(Nico Paul) #6

if the first OS installed in your disk partitions is doing this where it acts up when live disk is inserted then something is wrong with boot record. btrfs doesnt use swap at all because it could corrupt the disk by accident based on how it works. ive never had that issue before so im inclined to say your primary is not correct. what boot screen do you see to change OS at boot?


#7

i press f12 to select boot selection, there would be my local parrot and my live usb on the selection (uefi mode), and after selecting the live usb, when i restart my system, my local install won’t show up anymore in the boot selection.


(Nico Paul) #8

so its your bios boot screen? you should be seeing parrots grub screen which is grey if its installed correctly if not you have an issue with the primary bootloader


#9

no i did not express myself well, if i don’t press f12 then i will get to the grey grub screen, on which i can select my local parrot install.


(Amzker Pro Hacker) #10

Live boot not cause anything
It’s weird and new :face_with_head_bandage::face_with_head_bandage:

Have play with grub in live boot?

Ok well Firsr live boot And repair Your Grub
Then try to boot in local Parrot

And if have data ; Copy it before doing Experiment

And Just use etcher without thinking on partition :money_mouth_face:
Re-install it is best way


#11

i made my usb live using “dd” on linux, not etcher.

you’re right, when i have backed up what i need, i’ll try tweaking grub in live boot, thanks.


#12

so back to the problem, used parrot security live iso today, and after rebooting, the only boot option i have is my live usb, if i unplug it, i get the black screen with error “no boot devices found” and i’m stuck.

using live usb i can still see “/dev/sda” and can access my SSD and all the files inside, so i can back up everything at least, but i remember months ago i never had that problem, it started only recently (not just parrot, any live usb i plug will break my grub install…)

i tried on multiples computers and laptop and the problem is there, so do you guys have the same problem ?

EDIT : im seeing 1MB used in boot partition ??? what is happening each time i plug a live usb and boot in… ?


#13

This might be stupid, but…My Dell Laptop has a tendency to screw things up during “reboot”. It reboots in about 20 seconds, and often doesn’t load my wifi, and it also forgets, or forgets to check, on the other places to boot from. I have gotten used to shutting off, and restarting, instead of rebooting. That has solved several problems for me.


#14

mybad, when rebooting i meant shutting it off and then booting. i also use a dell laptop, i don’t have the wifi issues you have though, what is your model ?


#15

Its a Dell e6330, i7 2nd gen processor, and intel hd400 graphics. When I first started trying to install parrot, I had no luck installing from live cd. I tried disabling uefi, fastboot, and even changing my Raid to Ahci (my bios is still configured that way. But the only way I got this system to run properly is to install from the initial boot screen, down towards the bottom under “install - install with gtx intstaller”. since then no problems. Except I have to change the Marco compositor to “marco, no compositor” otherwise my XORG log is like a machine gun. It creates logs so fast, that my desktop slows down, and rotates the logs out so fast that it can cause me problems with Terminal.


(Nico Paul) #16

Did you use dd again to write it? You marked that you dont have a multiboot system is this correct?


#17

yes, i only have parrot installed on my laptop, and i always used dd the last months so i’m wondering if it’s what is causing that problem… so i tried rufus and it was weird, prone to lot of bugs, so i finally used etcher(great tool), but i really can’t take the risk to see if live work or not because i have homework on my laptop…

i will be able to try in a week and we will be fixed, but if it can helps, i tried to go live last time and reinstall grub, and i got error it did not let me install it on my “/dev/sda”, i don’t remember the errors though.