Virtualbox does not work after apt full-upgrade

Today I make system full upgrade on my parrot OS and noticed that my virualbox does not work.

Here is a log
cat /var/lib/dkms/virtualbox/6.1.26/build/make.log

Here is an some more virtualbox error after I want to again upgrade parrot
#sudo parrot-upgrade

As well I noticed that my /etc/apt/source.d/parrot.list is empty, should I leave it, or add here some lines? Would be great if someone will help, as I use virtualbox everyday. I tried reinstall dkms etc, look in google but nothing work.

The correct path is /etc/apt/sources.list.d/parrot.list

And I doubt it’s empty, otherwise send here a screenshot, because that would be really weird.

As for virtualbox, try to install it from the official virtualbox website.

I downloaded then installed virtualbox from official website via command:
sudo dpkg -i virtualbox-6.1_6.1.32-149290_Debian_bullseye_amd64.deb
Then I got this error:

I tried
apt install --reinstall virtualbox-dkms

sudo modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.15.0-15parrot1-amd64

I tried as well:
sudo apt -y full-upgrade -t parrot-backports
sudo apt purge "^virtualbox-.*"
sudo apt purge virtualbox-*
apt install virtualbox

Nothing works as for now, I reisnalled it plenty of times from yesterday.

/etc/apt/sources.d/parrot.list does not even exit.
but I found “parrot.list” in
/etc/apt/sources.list.d/parrot.list and it’s not empty (Hope $path making no difference here)

Thank you

Ok, that’s weird (I installed it easily via our doc). So let’s try again: remove everything, and do a sudo parrot-upgrade, then install virtualbox from the repo (sudo apt install virtualbox, and not from the backports repo). Let me know.

Yes, the right path is the one you mentioned, “/etc/apt/sources.list.d/parrot.list”.

install virtualbox ON REPOSITORY.

By mistake I deleted my posts which I make detailed. I’ll shortly write that I think for 90% that I answered NO first time when run #parrot-upgrade three days ago. When the upgrade of parrot core asked me to update the apt configuration files.
That’s why I probably have now lots of issues when I run again parrot-upgrade or apt upgrade and that’s maybe Virtualbox does not work properly. Here is output errors of #parrot-upgrade
command pastebin

check extension is installed or not

sudo apt-key adv --keyserver --recv-keys MIISSING_KEY_HERE

find your with the help of apt-key --help