VM image root password

Briefly describe your issue below:
I downloaded a VMware image of Parrot OS from osboxes.org and imported it into VMware. It came with a default user and password, and I used that to login. After login, I changed the name and password and started to use it. However, after a while I tried to start AnonSurf and Root terminal, but it asked me to enter administrator password. I entered the new password that I changed, but it didn’t accept it. Then I realized that I should try out the default root password from osboxes, and it worked.

In the FAQ here I read that the OS should not have a root password. This means that it is not the default setting and whoever set up this vm image set up a root password as well?

I also wanted to ask that having this default root password is how much a security risk (in vm)? I just used firefox and visited a few websites before I found out about this and I immediately changed the root password as well. Also, should I completely disable the root password somehow or I am fine with the new, unique root password?

I’m kinda new to this and I didn’t find anything on the topic that would satisfy me.
Thank you

What version of Parrot are you running?
Parrot Security OS 4.5 (Security Edition) vm image from osboxes.org

What method did you use to install Parrot?
imported the image in VMware

Configured to multiboot with other systems?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.