(VMW from ISO) Install keeps hanging

hello.

i am building my ‘lab’ back up amd have run into am issue with the ‘MATE Security 64 ISO’ image.

issue: with multiple attempts made, my installs are all stalling at 4% during the ‘file copying’ stage. **i have no HW or config conflicts that i am aware.

i am wondering if anyone has a solution…, other than to DL a fresh image and trying again (?).

thank y’all for any advisement, i am grateful…!! cheers.

~ ‘0x00’ /; >

you are trying to install new iso right?
what did you use to burn the image?
or are you installing on a VBOX?

hello @Nia.X6.Root.

thank you very much for your response. i did end up DL’ing a fresh image, used a different tool and was successful. the easiest answer, although a bit arduous process due to a few factors.

i had used ‘etcher’ for that particular burn. and grateful to Parrot Sec, it’s sandboxing and bit of s3c intuition, i will not be using that again and do not recommend it… it would not open, esp. being an .appimage. i was curious why it non-responsive. so i checked syslog first and it was right there.! it caught an attempt to load some arbitrary code into the exec of their .AppImage (.bin) file. i cant recall which exactly process caught it tgough, i’m sry.

i just grabbed a fresh iso image and used woeusb-dus, or ‘gnome disk utility’ and had a successful install…

i’m building out (rebuilding) my lab from start and was down to only one USB and a single hdd. with that success i have managed to continue and workaround a few more obatacles. i am building a multi-purpose / functional lab utilizing a w10 host with Workstation Pro. i do have several instances with varied linux flavors and kernel variants. and so i don’t have to land in this spot again, everything now has multiple forms of both autonomous and system-wide redundancy implemented.

i appreciate your intent to help and apologize for not providing the standard env variables needed for support.

thank you again brother.! cheers

[RESOLVED]

Well, as documentation, Parrot Dev Teams always suggest the use of Balena Etcher for burning the iso.
I have tried Etcher as well and it works perfectly. Some use rufus and they get problem if they don’t burn in dd mode.

Anyway, now your problem is solved. Cheers
Happy days ahead. Stay safe.

thank you for that tip my friend, i did not kniw that.

i do prefer to use rufus, simple GUI yet with enough adv. options to get the job done. however, at the time i did not have w10 installed. i only had Mint Live on a 4GB stick and a fresh 1TB WD.

thats good to know about Etcher, thank you. i’ve had issues in the past trying to use it due to incompatibility with their Electron framework, in different envs. as far as the the behavior i experienced trying to run it – it appeared to be an RCI/RCE attempt that was logged. i will try to recreate and if successful, i will forward that along.

i do remember that the .appimage (DL from their off. site), would not run, dbl-click nor term, it did not want to be sandboxed. it referred to at attempt to run arbitratry code inserted into the exec string, and read something like :

" --exec (’ ')/internal/path/etcher.bin "
if i read it correctly, () contained the offending, injected string. however, woeUSB, (‘dus’) variant was successful in creating my win10 bootable using Parrot Sec amd64. despite throwing cautionary disclaimers that it may fail due to it not being run in an emv using the offical Deban kernal. rolled the dice and won.

i have the highest respect, and appreciation for the Parrot Devs, (hi Vlad :slight_smile:), you and this great community… however, prior to any personal mods/config., it did not run the etcher appimage on the amd64 distro, 4.1 release.

my apologies @Nia.X6.Root, for the tl;dr response… i do appreciate your engagement. i will try to recreate the incident and post here as a KEDB tyoe reference.

thanks again my friend.! and yes, my lab, envs, power-tools and collection of malz in source and live to play with… (aka. reverse and study) is coming along great.! :smile:.

cheers

1 Like