Widevine Media Plugin Crash Firefox

$cat /etc/*release
DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.10
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION=“Parrot 4.10”
PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.10”
VERSION_ID=“4.10”
HOME_URL=“https://www.parrotsec.org/
SUPPORT_URL=“https://community.parrotsec.org/
BUG_REPORT_URL=“https://community.parrotsec.org/

┌─[***@parrot]─[~]
└──╼ $uname -a
Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux

┌─[***@parrot]─[~]
└──╼ $Software Etcher was used to make USB

Steps of making USB bootable Followed Instructions as per!

Deb Install

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)

Ran many steps to find more info about current issue on Firefox Since new Parrot Updates installed from current Stable Pen Distro from here and the correct repos on Beta ver! No issue with Widevine until running new Beta Kernals! Tried many suggestions from various Linux sources and Community with no resolve!

I ran new versions of Parrot along with latest official Parrot Firefox on Beta with new Kernal! That is where I had issue with Widevine Plugin!
It shows me this…
The Widevine Cdm has crashed submit a Crash report!
After checking and re-installing the plugin etc and various type suggestions no dice?


Looking for some help please I’m at a total loss for a Fix? Various updates of Firefox since the issue started with none stable Deb/Parrot Kernal Distros only!

I have no other Ideas apart from it being perhaps a Firejail issue? Any help much greatly apreciated thank you, the support here is much apreciated and terrific Community Spirit. Linux NOOB

Does it crash when you play the video at https://bitmovin.com/demos/drm

Hi Masmer.
Indeed it does.

This problem is now resolved thanks.
Uninstalled the Firefox V84 Browser and re-installed it! Was that simple something corrupted in addons.

1 Like