wiFi connected but loss web access(wifi is connected)

/

1. Your Parrot information

  • OS version:
    ```
    DISTRIB_ID=Parrot
    DISTRIB_RELEASE=4.10
    DISTRIB_CODENAME=rolling
    DISTRIB_DESCRIPTION=“Parrot 4.10”

     ```
    
  • Kernel version: run uname -a
    ```
    Linux parrot 5.8.0-1parrot1-amd64 #1 SMP Debian 5.8.7-1parrot1 (2020-09-14) x86_64 GNU/Linux

      ```
    
  1. How did you install OS?
    • Debian installer

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
```
 02:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

```
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

yes , referred in this community forum itself

4. How did you get this error? Are there any steps to procedure it?

i loss my internet access on wifi after 10 or 20 minutes
wifi is still connected but i cant access internet
(ping google.com doesnot work)
but if i reconnect to the same wifi i get internet access , and it again loss after some times of surfing

try pinging 8.8.8.8

if it works
add
8.8.8.8 at /etc/resolv.conf

i tried that too , but why the resolv.conf file get reset when i reboot? any idea?

after adding the file to /etc/resolv.conf, did you try restarting the network manager??
sudo systemctl restart NetworkManager.service

that resolv.conf gets reset on every boot by DHCP, it is build that way
that ping of 8.8.8.8 worked?

Continuing the discussion from wiFi connected but loss web access(wifi is connected):

I had similar issue, my card is Centrino N 6205 and it was working like a charm in MATE environment Security 4.10, but when I changed to KDE enviroment downloading ISO reinstalling everything from zero, in live and installed, I tried to connect my network but stays in “Configuring interface” and then device restarts. :frowning: