Wifi disabled?

sudo lshw -C network
*-network DISABLED
description: Wireless interface
product: Wi-Fi 6 AX201
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
logical name: wlp0s20f3
version: 20
serial: 3e:ef:c4:d5:b2:76
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.15.0-15parrot1-amd64 firmware=66.f1c864e0.0 QuZ-a0-jf-b0-66.u latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: iomemory:600-5ff irq:16 memory:600324c000-600324ffff

what is meant by network disabled??

NOTE my wifi is not working through wifi card… AX201

CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700GHz
Kernel: 5.14.0-9parrot1-amd64
OS: Parrot OS 5.0 (LTS) x86_64
Host: HP ProBook 450 G8 Notebook PC
DE: Plasma 5.20.5

same here!
really frustrating!!

what generation you are using?? can you please tell me…

Hello guys. Are you sure you don’t have the WiFi card locked at hardware level? Check with rfkill.

No, as you can see…

ID TYPE DEVICE SOFT HARD
0 bluetooth hci0 blocked unblocked
1 wlan phy0 unblocked unblocked
3 wlan phy2 unblocked unblocked

I concur, It is not uncommon for Laptops/netbook to go into hard lock when installing or updating Linux,
use the switch/key combination [depending on make] to switch off hard lock “flight mode” or rfkill from the terminal, both should work fine

It could be a hard block [but we have already asked you that]
it could also be caused by the wrong driver being installed
Can you run in the terminal inxi -Nnxz and paste back the result, [you may need to install inxi from the repository

Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3
IF: wlp0s20f3 state: down mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8168 v: 8.048.03-NAPI port: 3000
bus-ID: 0000:02:00.0
IF: enp2s0 state: down mac:
Device-3: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 3-6:5
IF: wlx1cbfce79b9b5 state: up mac:

please note wifi ax201 with drivers iwlwifi is not working

I have had a bit of time spare today, so after some searching round
the intel site says Set the authentication type as ‘WPA2-PSK’ and Encryption ‘AES

and if its a laptop under 2 yrs old, another work site says, if its a laptop, try booting up then hold down the power button for 60 seconds [this disconnects the MB button battery and bleeds the capacitors forcing the Bios to re-boot]

Sir,
My laptop is almost 6 months old and can you help me with this WPA2-PSK and AES encryption?? (I mean how and from where I can do it…)

This would normally be done in the network manager, But before you do that, have you tried already tried the basics, uninstall the drivers, and re-installing them ?

apt reinstall firmware-iwlwifi

Sir,
I have done all of that, still issue is alive…

Well, sorry to say, we have now gone through everything I can possibly think of, except the silly one, so here goes, connect the lapppy by the Ethernet cable into the router, open the connection manager, Is wired connection on? If not, try going to Wi-Fi and disabling then back to wired and try switching it on manually

Did it, No use Sadly