Wine32 install error,dependencies libstdc++6,libstdc++6:i386

Briefly describe your issue below:

Cannot install wine32 on Parrot. Trying to install wine32 gives the following:

The following packages have unmet dependencies:
libstdc++6 : Breaks: libstdc++6:i386 (!= 10.2.1-6) but 11.2.0-5 is to be installed
libstdc++6:i386 : Depends: libc6:i386 (>= 2.32) but 2.31-13 is to be installed
Breaks: libstdc++6 (!= 11.2.0-5) but 10.2.1-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Cannot install libwine:i386 on Parrot. Trying to install libwine:i386 gives the following:

The following packages have unmet dependencies:
libstdc++6 : Breaks: libstdc++6:i386 (!= 10.2.1-6) but 11.2.0-5 is to be installed
libstdc++6:i386 : Depends: libc6:i386 (>= 2.32) but 2.31-13 is to be installed
Breaks: libstdc++6 (!= 11.2.0-5) but 10.2.1-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

I already have i386 architecture, ran apt full-upgrade, apt install --fix-missing and wine wine64 libwine fonts-wine installed.

  • Parrot version in use
    4.11

  • Kernel version
    5.10.0-8parrot1-amd64

  • Logs/Terminal output

┌─[parrot@parrot]─[~]
└──╼ $sudo apt update && sudo apt full-upgrade && sudo apt install --fix-missing[sudo] password for parrot:
Hit:1 https://deb.parrot.sh/parrot rolling InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:3 https://repo.protonvpn.com/debian stable InRelease
Hit:4 https://deb.parrot.sh/parrot rolling-security InRelease
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
8 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

┌─[parrot@parrot]─[~]
└──╼ $sudo apt install wine wine64 libwine fonts-wine
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
fonts-wine is already the newest version (5.0.3-3).
libwine is already the newest version (5.0.3-3).
libwine set to manually installed.
wine is already the newest version (5.0.3-3).
wine64 is already the newest version (5.0.3-3).
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

┌─[parrot@parrot]─[~]
└──╼ $sudo apt install wine32
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libstdc++6 : Breaks: libstdc++6:i386 (!= 10.2.1-6) but 11.2.0-5 is to be installed
libstdc++6:i386 : Depends: libc6:i386 (>= 2.32) but 2.31-13 is to be installed
Breaks: libstdc++6 (!= 11.2.0-5) but 10.2.1-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

┌─[✗]─[parrot@parrot]─[~]
└──╼ $sudo apt install libwine:i386
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libstdc++6 : Breaks: libstdc++6:i386 (!= 10.2.1-6) but 11.2.0-5 is to be installed
libstdc++6:i386 : Depends: libc6:i386 (>= 2.32) but 2.31-13 is to be installed
Breaks: libstdc++6 (!= 11.2.0-5) but 10.2.1-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

1 Like

Same issue… and im trying hard to install a windows app that i really need!
I tried to install libstdc++6:i386 11.2.0-5 and told me that can NOT configure the installation cuz libstdc++6 needs to be same version…
libc6:i386 (>= 2.32) but 2.31-13 is to be installed (already 2.31-13 installed but doesn’t recognize it)

Update

Now its been Package ‘libstdc++6:i386’ has no installation candidate

  • Logs/Terminal output

┌─[parrot@parrot]─[~]
└──╼ $sudo apt install wine32
[sudo] password for parrot:
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libicu67:i386 : Depends: libstdc++6:i386 (>= 5.2) but it is not installable
E: Unable to correct problems, you have held broken packages.
┌─[✗]─[parrot@parrot]─[~]
└──╼ $sudo apt install libstdc++6:i386
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Package libstdc++6:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libstdc++6:i386’ has no installation candidate

synaptic , check in custom filter for broken …
after that is solved, I would update the system first

sudo apt update
sudo apt full-upgrade

There is no broken packages in synaptic custom filter.

same here… no broken packages

stable repository

deb Index of /parrot/ rolling main contrib non-free
deb Index of /parrot/ rolling-security main contrib non-free
deb-src Index of /parrot/ rolling non-free contrib main
deb-src Index of /parrot/ rolling-security non-free contrib main

Hi all,
Same problem for me.
Can’t install wine32 or steam on a fresh Parrot OS installation. :roll_eyes:

I hope it will be fixed soon.

let’s move back on kali… there was no strange issues :face_with_thermometer:

1 Like

Except that I use the Home version, not the Pro.
I’m not looking to do “pen testing” with it, but to create a secure workstation with the possibility to install some applications from windows and steam. :wink:
I have not yet been able to test the Pro version of Parrot OS but I imagine that this bug is also there.

Same issue here, reinstalling of OS didn’t help. It looks like the same problem was there 2 years ago (Wine32 Dependencies - #4 by dmknght). dmknght said that they will fix that asap, but it’s been a while and it’s still a problem. Maybe they’ve already fixed that and we’re doing something wrong?

I faced the same problem, let’s hope that they will fix it soon