I had an error connecting to my VPN. So I ran update/upgrade…

Hours later it froze at 51%.

Rebooted, wasn’t able to get into GUI stuck in a boot loop (blinking cursor/ mouse pointer? Tried going into previous versions (installs) same problem.

Tried finsihing upgrading in non GUI, froze again at 5%.

Rebooted go into GUI.
I tried every single command line I could find.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get upgradable
sudo apt full-upgrade
sudo apt-get upgrade --force
sudo apt autoremove

sudo apt remove wireguard-dkms --purge && sudo apt autoremove -y && sudo apt update -y

sudo apt-get install wireguard
sudo apt-get remove wireguard
apt show wireguard
sudo dpkg --configure -a
sudo apt update && apt upgrade && reboot

Nothing works :frowning: it says Wireguard is broken (very unstable) blablabla. I tried removing /updating in Synaptic Manager as well. It never shows any progress. I keep killing apps that prevent me from updating. If i try to re-install my VPN’s app says required to be installed wireguard-dkms.

Please any help would be great.

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
  3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release
    Copy output here
  • Kernel version: run uname -a
    Copy output here

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.9
Desktop Environment: Mate
Edition: Home

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?

    • Software was used to make USB
    • Steps of making USB bootable
  2. How did you install OS?

    • Debian installer or Calamares installer?

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
    Copy output here
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

4. How did you get this error? Are there any steps to procedure it?

1. I installed this
2. I ran this new software
3. It shows me this or that

5. Error log or screenshot

** Insert error log and screenshot here**

6. If you have any idea or suggestion about this issue please tell us

** Your information **

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea


sudo apt-get upgrade can break you system.


How do I upgrade my system?

First please, do NOT use apt-get upgrade . Because ParrotOS is a rolling distribution and how APT works, the command will cause considerable problems to your system. We don’t recommend apt-get in general as the command is not really meant for end-users. The following are the recommended ways to update your system:

  1. First method

Open a terminal window (default is Alt+T) and launch the following command:

sudo parrot-upgrade

Meanwhile, Wireguard’s installation website says to install while at a root prompt.

#apt install wireguard

Thanks for the reply. Note taken for the future. This is what I get after:

sudo parrot-upgrade

dpkg: error processing package wireguard-dkms (–configure):
package is in a very bad inconsistent state; you should
reinstall it before attempting configuration
Errors were encountered while processing:
failed to fix interrupted upgrades
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
Recommended packages:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
1 not fully installed or removed.
Need to get 0 B/254 kB of archives.
After this operation, 1,024 B disk space will be freed.
Do you want to continue? [Y/n] y
apt-listchanges: Reading changelogs…
(Reading database … 668366 files and directories currently installed.)
Preparing to unpack …/wireguard-dkms_1.0.20201221-1_all.deb …

Progress: [ 0%] […]

It hangs forever at 0%. I guess it’s broken… :frowning:

Yeah, probably better to start from scratch if that’s not too inconvenient. Then after a parrot-upgrade, see if you can install wireguard successfully. If not, then let us know. :slight_smile:

PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”

Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux

Info I meant to post originally ^^^
So I’m making a backing up, in hopes of starting clean install.

Thanks for your help

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.