wlan0 not exist

hi i just installed parrot is, mostly because i needed a light Linux distro
i used it for 3 days, day 1 no problem, but as i was obbligated to move i had to change wifi where to get connected, wireless connection where not showing up in the connections button up right, i went for the easiest options and i rebooted the system, was working, as i came back home the day after that i wanted to connect to my home’s wifi (the same as i installed parrot with) but isn’t showing nothing even after rebooting the system, not only i tried ifconfig
wasn’t showing any network interface ifconfig wlan0 up as result *wlan0: ERROR while getting interface flags: no device * looking in other forums i found some people reinstalling nic drivers but idk what mine should be (i guess i should download them with a pen drive) also other command as sudo il link set wlan0 up i think a newer version of the ipconfig (yeah i haven’t used Linux in a while) but still don’t working, but actually a command shown up my nic lspci -nn | grep 0280 it shows 02:00.0 Network controller [0280] : Intel Corporation Wi-Fi 6 AC200 [8086:2723] (rev la) anyone knows what to do?
thanks

Did you install parrot to the main hard drive or to in a VM, if it’s in a VM then you use the host OS to control the connection

ciao, ho installato il sistema operativo su un hard disk interno al portatile, il secondo slot per l’esattezza

If possible, please run in a terminal inxi -N and paste the report back here

i solved the problem downloading the nic drivers in another pc, then with a pen drive i installed them on parrot os, but thank you anyway

1 Like

I’m having the same exact problem but I didn’t ever have it working and it’s not a vm I wiped my computer. It says it’s intel 82567LM-3 gigabit network driver e1000e

with another pc look on internet for your nic drivers, download the lastest and with a pen drive bring 'em in your parrot PC, so Download them, reboot and try to see, this worked for me at least, if it doesn’t try to look at the problem in general, rarely is correlated to the Linux distro most of the time the reason is another :wink: