X server Nvidia Driver

Hello Guys,
I have a problem with nvidia card driver , by mistake i installed x server drivers from package manager , and i tried to rollback the driver but no thing is working ,
in this driver i my display is not detected and i can’t change the screen resolution,

https://i.imgur.com/EvaiJ5o.png

My Card Is NVIDIA Quadro M1000M
Nvidia Version

https://i.imgur.com/q0rIGCv.png

Nvidia-Smi

https://i.imgur.com/CfY99LY.png

i already downloaded the m1000m driver from nvidia website and i tired to install it using chmod +x sh , ./ " but i always get the same error " ERROR: You appear to be running an X server; please exit X before installing "
i killed the xorg process after i logged out then i press CTRL , ALT, F1 service lightdm stop , sudo -s kill -9 , init 3 …
when ever im trying to install the driver after i stopped the X server error msg , i got another error " received Signal sigterm; aborting
"

https://i.imgur.com/44mmCLM.jpg

"
is there any solution to get my old driver back ??

i Tired every thing lol

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
5.3.0-3parrot3-amd64
PRETTY_NAME=“Parrot GNU/Linux 4.7”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.7”
VERSION_ID=“4.7”

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

You tried starting the operation from recovery mode(from grub) so the server doesn’t start at all and thus never has to be stopped?

i tired service lightdm Stop , recovery mode from the first loading screen ,
when ever i killed the process called " Xorg " using sudo -s kill -9 the x server error msg not showing but when the count down start from 10 sec to 1 i got the another error

https://i.imgur.com/44mmCLM.jpg

I Also Tired These Commands

sudo systemctl status systemd-modules-load.service
sudo journalctl -u systemd-modules-load.service
sudo /usr/lib/systemd/systemd-modules-load

Results



DeepinScreenshot_desktop_window_20191223193008

Why? If you actually started from recovery mode there is no x-server running and there’s no display manager either. Also what did you download NVidia supposed to have a self extracting “.run” archive?
Did you configure the X server to use the Nvidia driver?
Did you disable Noveau?
The log shows in very clear language that certain files are missing from their filepaths, where are these files? Do they exist? Did you even actually build the module in the first place, if it never successfully built there is nothing to be installed.

Did you bother to read nvidia’s extensive documentation?

Knox, your not configured to multiboot, so lets start fresh. can you please just reinstall Parrot? Should Only take 20 Minutes maybe 30 tops. You have decent hardware, and setup for install on Encrypted LVM use the automatic using the whole drive. or if you know what your doing use the options to make a 512MB boot/EFI or “EFS” this partion will not be encrypted and will not be a LVM either, but lets be safe and then use the option to install /root and everything else on encrypted LVM on 1 partion and you can use that the Flag -I’m a beginner and install everything else to 1 partion please… I still install Debian-base/Debian-Hybrids like that. Its better I think for security reasons it tightens everything up. Unless you want to have suspend and hibernation type features. Or just do what you did before to get to the Nvidia install point. Now after you update and make sure its you type sudo parrot-upgrade, NOT SUDO APT UPGRADE <-- do not do this. use parrot-upgrade ALWAYS! .

now after a reboot. you want to install the package “timeshift” and while it installs hop on youtube and watch a 3 min tutorial on the 4 buttons your going to hit to configure it. unless its now standard on Parrot its "sudo apt install timeshift " it literally gives you the ability to time travel using btrfs file system or everything else on rsynch. it take me longer to type it out on here than it would for you to watch it on youtube. just google it. “timeshift for linux install and configure”. and other than typing rmdir -F /* you pretty much can recover almost anything else, you might even be able to recover from that command if you dont reboot. im not 100% on that.

and then you never have to ask for help on a forum again, you be able to help other on forums, because you have so much experience messing things up and fixing them. Now go do this, ill figure out what you need for nvidia. I just wanted you to get this. give me 10 to 15 minutes ill figure out what you need to start hacking away OK?

the nvidia package should just be the same number as the kernel your runing like sudo apt install nvidia530xxxxx something like that. and when Parrot updates to 5.4 kernel you can install the bleading packages on Arch right now its nvidia540.44 or was like 3 hours ago last I looked at them Packages.

And listen, its going to be a a while before your totally updated, but I guarantee you this is easier then 20 replays from us and yourself trying to figure out what exactly you did and what order you need to go in reverse to fix it. yadda yadda and you can really hack your system, just dont install timeshift on a real production machine thats designed for making money as the ONLY WAY OF RECOVERING because its not a 100% like I said rmdir -f /* I think will override anything timeshift can fix. But its great for learning with if you dont have a great knowledge base of recovery software.

Last thing, you learn allot from the mistakes you make on linux, your learn next to nothing from those first time achievements. OKAY its how it all works.

copy paste this in terminal:

lspci -nn | egrep -i “3d|display|vga”

if you get a 1 line return like this:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G80 [GeForce 8800 GTS] [10de:0193] (rev a2)

sudo apt install nvidia-detect

Then from a terminal:

nvidia-detect

(if something liek this comes out your good to go)
Detected NVIDIA GPUs:
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1)
Your card is supported by the default drivers.
It is recommended to install the
nvidia-driver
package.

if this

lspci -nn | egrep -i “3d|display|vga”

command returns more than one line of output, you have an Optimus (hybrid) graphics chipset, and the instructions on the wiki follow these links Check the Bumblebee and nvidia-xrun

Ive no experience with Optimus but you should have timeshift now so you can apt-search nvidia at the terminal and look through the options but now unlike about 1-2 years ago 99 out of 100 times nvidia-detect or nvidia-driver is the most you type to figure out (NON-OPTIMUS) cards. Plus your using the VM KDE (you can also look in the propriarity KDE package manager its called Discover and its in the apps under System or Settings or Utilities something liek that. Plus thiers going to be I believe a fast link to the app in the far right botom corner and they might have an easy way to install nvidia by just checking a box, its that easy if its avalible. Kubuntu 19.04 came with nvidia gui installer like that in Discover and I love the Look of KDE Plasma 5 . But on my system its very unstable from the start and just gets worse over time, for me at least.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.